summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVasile Dumitrascu <va511e@yahoo.com>2017-03-29 00:54:57 +0200
committerLudovic Courtès <ludo@gnu.org>2017-03-30 11:15:16 +0200
commit239cf024b4200ce74bb0d437437903c1298343d3 (patch)
tree697c6a8bf0af1b142c58d2fd7ec5299b57ffd2b0
parent6a91c5f2dcc1d58c8815e37d837943c181ed74db (diff)
gnu: Add emacs-highlight-sexp.
* gnu/packages/emacs (emacs-highlight-sexp): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index d0554519fc..4e2d2561ab 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4009,3 +4009,24 @@ modern look. It implements a new HTML back-end for exporting org-mode docs as
HTML compatible with Twitter Bootstrap. By default, HTML is exported with
jQuery and Bootstrap resources included via osscdn.")
(license license:gpl3+)))
+
+(define-public emacs-highlight-sexp
+ (package
+ (name "emacs-highlight-sexp")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/daimrod/highlight-sexp/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0jwx87qkln1rg9wmv4qkgkml935fh2pkgrg5x4ca6n5dgb4q6rj1"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/daimrod/highlight-sexp")
+ (synopsis "Minor mode that highlights the s-exp at the current position")
+ (description
+ "This Emacs package highlights the s-exp at the current position.")
+ (license license:gpl3+)))