summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-09-01 13:59:28 +0800
committerBen Woodcroft <donttrustben@gmail.com>2017-09-01 14:45:57 +0800
commit25bd1fc1c12ee2dfbcb12daf36f25285a4f7e55a (patch)
tree66f18221eb81df3d0b258e7f666fd8ae7a0d0091
parent43d01672a11814ca4cdcc592544064d75d1653f0 (diff)
gnu: metabat: Update to 2.12.1.
* gnu/packages/patches/metabat-remove-compilation-date.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/bioinformatics.scm (metabat): Update to 2.12.1. [source]: Remove it. Use url-fetch.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/bioinformatics.scm16
-rw-r--r--gnu/packages/patches/metabat-remove-compilation-date.patch16
3 files changed, 7 insertions, 26 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 2e40026e53..8c683b8e42 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -846,7 +846,6 @@ dist_patch_DATA = \
%D%/packages/patches/mcrypt-CVE-2012-4527.patch \
%D%/packages/patches/mesa-skip-disk-cache-test.patch \
%D%/packages/patches/mesa-wayland-egl-symbols-check-mips.patch \
- %D%/packages/patches/metabat-remove-compilation-date.patch \
%D%/packages/patches/metabat-fix-compilation.patch \
%D%/packages/patches/mhash-keygen-test-segfault.patch \
%D%/packages/patches/mingw-w64-5.0rc2-gcc-4.9.3.patch \
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 70418cd977..37980f3756 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3475,19 +3475,17 @@ form of assemblies or reads.")
(define-public metabat
(package
(name "metabat")
- (version "2.11.3")
+ (version "2.12.1")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://bitbucket.org/berkeleylab/metabat.git")
- (commit "d0ad65367ffc8e08d1a9dd1388d6170daa047e5c")))
- (file-name (string-append name "-" version "-checkout"))
+ (method url-fetch)
+ (uri (string-append "https://bitbucket.org/berkeleylab/metabat/get/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1rlsrkz8iq8xah65222p055kzv5i3szz8bwysnvnh0pv72wvv6ww"))
- (patches (search-patches "metabat-remove-compilation-date.patch"
- "metabat-fix-compilation.patch"))))
+ "1hmvdalz3zj5sqqklg0l4npjdv37cv2hsdi1al9iby2ndxjs1b73"))
+ (patches (search-patches "metabat-fix-compilation.patch"))))
(build-system gnu-build-system)
(arguments
`(#:phases
diff --git a/gnu/packages/patches/metabat-remove-compilation-date.patch b/gnu/packages/patches/metabat-remove-compilation-date.patch
deleted file mode 100644
index 7672205b22..0000000000
--- a/gnu/packages/patches/metabat-remove-compilation-date.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Remove the reference to the compilation date so that the build is
-reproducible.
-
-diff --git a/src/metabat.cpp b/src/metabat.cpp
-index 88e06de..c95cb1a 100644
---- a/src/metabat.cpp
-+++ b/src/metabat.cpp
-@@ -49,7 +49,7 @@ int main(int ac, char* av[]) {
- po::notify(vm);
-
- if (vm.count("help") || inFile.length() == 0 || outFile.length() == 0) {
-- cerr << "\nMetaBAT: Metagenome Binning based on Abundance and Tetranucleotide frequency (version " << version << "; " << __DATE__ << " " << __TIME__ << ")" << endl;
-+ cerr << "\nMetaBAT: Metagenome Binning based on Abundance and Tetranucleotide frequency (version " << version << "; unknown compilation date)" << endl;
- cerr << "by Don Kang (ddkang@lbl.gov), Jeff Froula, Rob Egan, and Zhong Wang (zhongwang@lbl.gov) \n" << endl;
- cerr << desc << endl << endl;
-