summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2022-11-06 21:15:24 -0500
committerChristopher Baines <mail@cbaines.net>2022-11-07 20:51:31 +0100
commit2c1fc058c58c716575260170ff4f3cf9afbf24fb (patch)
tree33d9a5a0110cecfb04f0223a7d25a582adaca104
parent9ad311ec15c05efc78f74252e7eb6cddfb0b5cea (diff)
gnu: teximpatient: Update to 2.4-0.e3666ab.
* gnu/packages/tex.scm (teximpatient): Update to 2.4-0.e3666ab. [source]: Use git repository. [native-inputs]: Add autoconf. [arguments]: Make build reproducible. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/tex.scm94
1 files changed, 56 insertions, 38 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9b0c4743cc..81f74f17df 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8211,46 +8211,64 @@ develop documents with LaTeX, in a single application.")
(license license:gpl2+)))
(define-public teximpatient
- (package
- (name "teximpatient")
- (version "2.4")
- (source (origin
- (method url-fetch/tarbomb)
- (uri (string-append "mirror://gnu/" name "/" name "-"
- version ".tar.gz"))
- (sha256
- (base32
- "0h56w22d99dh4fgld4ssik8ggnmhmrrbnrn1lnxi1zr0miphn1sd"))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; there are none
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-packaging-error
- (lambda* (#:key inputs #:allow-other-keys)
- ;; This file should have been part of the tarball.
- (install-file (car
- (find-files
- (assoc-ref inputs "automake")
- "^install-sh$"))
- ".")
- ;; Remove generated file.
- (delete-file "book.pdf")
- #t)))))
- (native-inputs
- `(("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
- texlive-palatino
- texlive-zapfding
- texlive-knuth-lib
- texlive-mflogo-font
- texlive-pdftex)))
- ("automake" ,automake)))
- (home-page "https://www.gnu.org/software/teximpatient/")
- (synopsis "Book on TeX, plain TeX and Eplain")
- (description "@i{TeX for the Impatient} is a ~350 page book on TeX,
+ ;; The homepage seems to be distributing this version which is currently the
+ ;; most recent commit
+ (let ((commit "e3666abff186832fd9c467ceda3958058f30bac2")
+ (revision "0"))
+ (package
+ (name "teximpatient")
+ (version (git-version "2.4" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://git.savannah.gnu.org/git/teximpatient.git/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0r30383nmly7w29il6v3vmilnnyrzak0x0qmabjvnpaga9ansjmi"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;there are none
+ #:allowed-references ("out")
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'fix-build
+ (lambda* (#:key inputs #:allow-other-keys)
+ (chdir "teximpatient")
+
+ ;; Remove generated files
+ (for-each delete-file
+ '("book.pdf"
+ "book.aux"
+ "book.ccs"
+ "book.log"
+ "book.idx"
+ "config.log"
+ "config.status"
+ "configure"
+ "Makefile"))
+ (delete-file-recursively "autom4te.cache")
+
+ ;; make build reproducible
+ (substitute* "eplain.tex"
+ (("timestamp.*%")
+ (string-append "timestamp{"
+ ,version "}"))))))))
+ (native-inputs (list autoconf automake
+ (texlive-updmap.cfg (list texlive-amsfonts
+ texlive-palatino
+ texlive-zapfding
+ texlive-knuth-lib
+ texlive-mflogo-font
+ texlive-pdftex))))
+ (home-page "https://www.gnu.org/software/teximpatient/")
+ (synopsis "Book on TeX, plain TeX and Eplain")
+ (description
+ "@i{TeX for the Impatient} is a ~350 page book on TeX,
plain TeX, and Eplain, originally written by Paul Abrahams, Kathryn Hargreaves,
and Karl Berry.")
- (license license:fdl1.3+)))
+ (license license:fdl1.3+))))
(define-public lyx
(package