summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-02-05 03:16:18 -0500
committerLeo Famulari <leo@famulari.name>2016-02-22 00:40:25 -0500
commit3276517cdcd2dfe7f2bad40eb22d94841775056a (patch)
tree982d4da3ba3c1d1920b1e59ab0f02ae8a8124bcb
parent2de98febb32cc1b2816213c9056a90d6cf5730b0 (diff)
gnu: Add python-sphinxcontrib-programoutput.
* gnu/packages/python.scm (python-sphinxcontrib-programoutput, python2-sphinxcontrib-programoutput): New variables.
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 740126f99a..91fa25674f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8104,3 +8104,30 @@ programmatically interfacing with your system's $EDITOR.")
(inherit (package-with-python2
(strip-python2-variant python-editor)))
(inputs `(("python2-setuptools" ,python2-setuptools)))))
+
+(define-public python-sphinxcontrib-programoutput
+ (package
+ (name "python-sphinxcontrib-programoutput")
+ (version "0.8")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "sphinxcontrib-programoutput" version))
+ (sha256
+ (base32
+ "098as6z1s0gb4dh5xcr1fd2vpm91zj93jzvgawspxf5s4hqs0xhp"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-docutils" ,python-docutils)
+ ("python-sphinx" ,python-sphinx)))
+ (synopsis "Sphinx extension to include program output")
+ (description "A Sphinx extension to literally insert the output of arbitrary
+commands into documents, helping you to keep your command examples up to date.")
+ (home-page "https://github.com/lunaryorn/sphinxcontrib-programoutput")
+ (license bsd-2)
+ (properties `((python2-variant . ,(delay python2-sphinxcontrib-programoutput))))))
+
+(define-public python2-sphinxcontrib-programoutput
+ (package
+ (inherit (package-with-python2
+ (strip-python2-variant python-sphinxcontrib-programoutput)))
+ (native-inputs `(("python2-setuptools" ,python2-setuptools)))))