summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authornixo <nicolo@nixo.xyz>2021-01-19 11:23:37 +0100
committerLudovic Courtès <ludo@gnu.org>2021-03-20 22:29:14 +0100
commit3291e4ba97e94d09a35615d79ca07c43fa679403 (patch)
tree2f0ae5fb5ed583e0a09ad8c388aab6cc1b62523f
parenta06db9c1ee8b36021d384e7552f1cf1c41208517 (diff)
gnu: Add julia-mbedtls-jll.
* gnu/packages/julia-xyz.scm (julia-mbedtls-jll): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/julia-xyz.scm43
1 files changed, 42 insertions, 1 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index b89733c412..ab3497700a 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -20,7 +20,8 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix git-download)
- #:use-module (guix build-system julia))
+ #:use-module (guix build-system julia)
+ #:use-module (gnu packages tls))
(define-public julia-adapt
(package
@@ -215,6 +216,46 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
and printing JSON documents.")
(license license:expat)))
+(define-public julia-mbedtls-jll
+ (package
+ (name "julia-mbedtls-jll")
+ ;; version 2.25.0+0 is not compatible with current mbedtls 2.23.0,
+ ;; upgrade this when mbedtls is updated in guix
+ (version "2.24.0+1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/MbedTLS_jll.jl")
+ (commit (string-append "MbedTLS-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0kk9dlxdh7yms21npgrdfmjbj8q8ng6kdhrzw3jr2d7rp696kp99"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; No runtests.jl
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("generate_wrapper_header.*")
+ (string-append
+ "generate_wrapper_header(\"MbedTLS\", \""
+ (assoc-ref inputs "mbedtls-apache") "\")\n"))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$"))
+ #t)))))
+ (inputs `(("mbedtls-apache" ,mbedtls-apache)))
+ (propagated-inputs `(("julia-jllwrappers" ,julia-jllwrappers)))
+ (home-page "https://github.com/JuliaBinaryWrappers/MbedTLS_jll.jl")
+ (synopsis "Apache's mbed TLS binary wrappers")
+ (description "This Julia module provides @code{mbed TLS} libraries and
+wrappers.")
+ (license license:expat)))
+
(define-public julia-orderedcollections
(package
(name "julia-orderedcollections")