summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-03-20 19:09:04 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-04-16 17:02:34 +0300
commit452454e30cfde183bb3b8954b844a9d6c9f81bcc (patch)
treef1cc532810f480e95e3b94e83b893d1f22ba428e
parent93aba854dbc559e863d1127a30cdb60eadaa113b (diff)
gnu: Add emacs-epkg.
* gnu/packages/emacs.scm (emacs-epkg): New public variable.
-rw-r--r--gnu/packages/emacs.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ee3fe145fb..e2b901cd3a 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -7819,3 +7819,47 @@ on what kind of objects can be stored; it isn't intended to store arbitrary
objects. All objects have to share a common superclass and subclasses cannot
add any additional instance slots.")
(license license:gpl3)))
+
+(define-public emacs-epkg
+ ;; The release version is to old for the current database scheme.
+ (let ((commit "432312b9583ed7b88ad9644fd1bf2183765a892e"))
+ (package
+ (name "emacs-epkg")
+ (version (git-version "3.0.0" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacscollective/epkg.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0d882kahn7a0vri7a9r15lvmfx1zn2hsga6jfcc6jv0hqbswlb2k"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-closql" ,emacs-closql)
+ ("emacs-dash" ,emacs-dash)))
+ (home-page "https://emacsmirror.net")
+ (synopsis "Browse the Emacsmirror package database")
+ (description "This package provides access to a local copy of the
+Emacsmirror package database. It provides low-level functions for querying
+the database and a @file{package.el} user interface for browsing the database.
+Epkg itself is not a package manager.
+
+Getting a local copy:
+
+@example
+git clone https://github.com/emacsmirror/epkgs.git ~/.emacs.d/epkgs
+cd ~/.emacs.d/epkgs
+git submodule init
+git config --global url.https://github.com/.insteadOf git@@github.com:
+git submodule update
+@end example
+
+Some submodule may be missing. In this case Git will prompt for a GitHub user
+name and password. To skip it press a @key{Return} key.
+
+You could get a Epkg package list by invoking @code{epkg-list-packages} in
+Emacs.")
+ (license license:gpl3+))))