summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-08-19 14:05:01 +0200
committerMarius Bakke <marius@gnu.org>2020-11-21 01:21:32 +0100
commit53346d033287112fb30263eb5a35cf7f2f5621a0 (patch)
tree2a2f0fd98725c4856e6970061cfe8ede15cf94f5
parent079de0b14267da0e46446cf54b9fc18f6e33b452 (diff)
gnu: Add python-jose.
* gnu/packages/python-web.scm (python-jose): New public variable.
-rw-r--r--gnu/packages/python-web.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 14e40b1f07..2ba69ba53d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -566,6 +566,46 @@ Swartz.")
(base32
"0ppgjplg06kmv9sj0x8p7acczcq2mcfgk1jdjwm4w5w40b0vj5pm")))))))
+(define-public python-jose
+ (package
+ (name "python-jose")
+ (version "3.2.0")
+ (home-page "http://github.com/mpdavis/python-jose")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xmnf8whzv2gnkkdv0fqcn9qwmcc7y647p4kw9fi3lvcp9kch8vi"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (invoke "pytest" "-vv")
+ (format #t "test suite not run~%"))
+ #t)))))
+ (native-inputs
+ `(;; All native inputs are for tests.
+ ("python-pyasn1" ,python-pyasn1)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-runner" ,python-pytest-runner)))
+ (propagated-inputs
+ `(("python-cryptography" ,python-cryptography)
+ ("python-rsa" ,python-rsa)
+ ("python-six" ,python-six)))
+ (synopsis "JOSE implementation in Python")
+ (description
+ "The @dfn{JavaScript Object Signing and Encryption} (JOSE) technologies
+- JSON Web Signature (JWS), JSON Web Encryption (JWE), JSON Web Key (JWK), and
+JSON Web Algorithms (JWA) - collectively can be used to encrypt and/or sign
+content using a variety of algorithms.")
+ (license license:expat)))
+
(define-public python-jsonpickle
(package
(name "python-jsonpickle")