summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-11-08 04:00:02 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-12-05 09:44:37 -0500
commit5eea20051877044fd4d2fa2ea075d5f66824f123 (patch)
tree88f830ac6723750227341b12690cd94ccc0ff33c
parent3859ac12d6a5648d8cfc7d521218c0d582b6d4c5 (diff)
gnu: Add python-werkzeug.
* gnu/packages/python.scm (python-werkzeug, python2-werkzeug): New variables.
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 6923724488..d2d6b91138 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6368,3 +6368,31 @@ timestamps.")
(define-public python2-pyrfc3339
(package-with-python2 python-pyrfc3339))
+
+(define-public python-werkzeug
+ (package
+ (name "python-werkzeug")
+ (version "0.11.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pypi.python.org/packages/source/W/Werkzeug"
+ "/Werkzeug-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1gzwn1lkl90f3l1nzzxr7vjhm21qk8f837i8rvny5a209fcrhkzb"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "http://werkzeug.pocoo.org/")
+ (synopsis "Utilities for WSGI applications")
+ (description "One of the most advanced WSGI utility modules. It includes a
+powerful debugger, full-featured request and response objects, HTTP utilities to
+handle entity tags, cache control headers, HTTP dates, cookie handling, file
+uploads, a powerful URL routing system and a bunch of community-contributed
+addon modules.")
+ (license x11)))
+
+(define-public python2-werkzeug
+ (package-with-python2 python-werkzeug))