summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-04-25 21:37:52 +0200
committerLudovic Courtès <ludo@gnu.org>2021-04-26 16:46:56 +0200
commit601d86183a101db07be373a5414cce7a75d800f4 (patch)
treeb7cd234add2a78b45a03bf3069bab060fcb8f844
parent075de760d314b4b191a524f02255699746d4064c (diff)
gnu: xfce, mate: Propagate 'font-dejavu'.
Fixes <https://bugs.gnu.org/47713>. Reported by bo0od <bo0od@riseup.net>. This ensures applications such as IceCat can properly text (numbers in the case of IceCat). * gnu/packages/enlightenment.scm (enlightenment)[propagated-inputs]: Add FONT-DEJAVU. * gnu/packages/mate.scm (mate)[propagated-inputs]: New field. * gnu/packages/xfce.scm (xfce)[propagated-inputs]: New field.
-rw-r--r--gnu/packages/enlightenment.scm6
-rw-r--r--gnu/packages/mate.scm5
-rw-r--r--gnu/packages/xfce.scm4
3 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index 15ea89454f..079d60e45a 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -36,6 +36,7 @@
#:use-module (gnu packages code)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages fribidi)
@@ -370,7 +371,10 @@ Libraries with some extra bells and whistles.")
(propagated-inputs
`(("efl" ,efl)
("libxkbcommon" ,libxkbcommon)
- ("wayland-protocols" ,wayland-protocols)))
+ ("wayland-protocols" ,wayland-protocols)
+
+ ;; Default font that applications such as IceCat require.
+ ("font-dejavu" ,font-dejavu)))
(home-page "https://www.enlightenment.org/about-enlightenment")
(synopsis "Lightweight desktop environment")
(description
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 44420147a3..82b2d6e0fd 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2019 Guy Fleury Iteriteka <hoonandon@gmail.com>
;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2020 Mathieu Othacehe <m.othacehe@gmail.com>
@@ -1580,6 +1580,9 @@ used to bring up authentication dialogs.")
("shared-mime-info" ,shared-mime-info)
("yelp" ,yelp)
("zenity" ,zenity)))
+ (propagated-inputs
+ ;; Default font that applications such as IceCat require.
+ `(("font-dejavu" ,font-dejavu)))
(synopsis "The MATE desktop environment")
(home-page "https://mate-desktop.org/")
(description
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index b4a8245548..fcddd08b91 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -36,6 +36,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages calendar)
#:use-module (gnu packages cdrom)
+ #:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
@@ -991,6 +992,9 @@ on your desktop.")
("xfce4-clipman-plugin" ,xfce4-clipman-plugin)
("xfce4-pulseaudio-plugin" ,xfce4-pulseaudio-plugin)
("xfce4-xkb-plugin" ,xfce4-xkb-plugin)))
+ (propagated-inputs
+ ;; Default font that applications such as IceCat require.
+ `(("font-dejavu" ,font-dejavu)))
(native-search-paths
;; For finding panel plugins.
(package-native-search-paths xfce4-panel))