summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-08-26 17:10:37 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-01 23:08:56 +0200
commit73bfc125ef61980920cd01691032153deba4b98d (patch)
treef780fcb6ea7b367f0bc7ebdfca385ae170926f84
parent2e072e37aa0c5cf0fc612c9e4d5540cec6189b13 (diff)
gnu: Add ruby-heredoc-unindent.
* gnu/packages/ruby.scm (ruby-heredoc-unindent): New variable.
-rw-r--r--gnu/packages/ruby.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index bfb98a0bff..34d883284d 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5739,3 +5739,29 @@ is compatible with stylesheets designed for pygments.")
(description "Hashie is a collection of classes and mixins that make Ruby
hashes more powerful.")
(license license:expat)))
+
+(define-public ruby-heredoc-unindent
+ (package
+ (name "ruby-heredoc-unindent")
+ (version "1.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "heredoc_unindent" version))
+ (sha256
+ (base32
+ "14ijr2fsjwhrkjkcaz81d5xnfa4vvgvcflrff83avqw9klm011yw"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("ruby-hoe" ,ruby-hoe)))
+ (home-page "https://github.com/adrianomitre/heredoc_unindent")
+ (synopsis "Heredoc indentation cleaner")
+ (description "This gem removes common margin from indented strings, such
+as the ones produced by indented heredocs. In other words, it strips out
+leading whitespace chars at the beggining of each line, but only as much as
+the line with the smallest margin.
+
+It is acknowledged that many strings defined by heredocs are just code and
+fact is that most parsers are insensitive to indentation. If, however, the
+strings are to be used otherwise, be it for printing or testing, the extra
+indentation will probably be an issue and hence this gem.")
+ (license license:expat)))