summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2018-08-24 12:18:27 +0530
committerArun Isaac <arunisaac@systemreboot.net>2018-08-26 11:37:25 +0530
commit7550f4b0ef250268af7b5cc97ea9e1215371cec4 (patch)
treef2febae254e47ef15dade9e3c94da962b9d0ec10
parentb625f3a5fbfa3badc294cdb7bc0c0399d8ca1839 (diff)
gnu: ghc-integer-logarithms: Update to 1.0.2.1.
* gnu/packages/haskell.scm (ghc-integer-logarithms): Update to 1.0.2.1. [inputs]: Move ghc-quickcheck, ghc-smallcheck, ghc-tasty, ghc-tasty-hunit, ghc-tasty-quickcheck, ghc-tasty-smallcheck ... [native-inputs]: ... to here. [home-page]: Update URI.
-rw-r--r--gnu/packages/haskell.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index eefc1dc0a6..cb4c0efef6 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5054,7 +5054,7 @@ occurrences of a substring (the first in case of overlaps) with another.")
(define-public ghc-integer-logarithms
(package
(name "ghc-integer-logarithms")
- (version "1.0.2")
+ (version "1.0.2.1")
(source
(origin
(method url-fetch)
@@ -5063,16 +5063,16 @@ occurrences of a substring (the first in case of overlaps) with another.")
version ".tar.gz"))
(sha256
(base32
- "0w5mhak181zi6qr5h2zbcs9ymaqacisp9jwk99naz6s8zz5rq1ii"))))
+ "1wj8kgjg5bn2yrs4zh9qfjv85cx6w998j9pi39yrbv305944mb9j"))))
(build-system haskell-build-system)
- (inputs
- `(("ghc-tasty" ,ghc-tasty)
- ("ghc-tasty-smallcheck" ,ghc-tasty-smallcheck)
- ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-smallcheck" ,ghc-smallcheck)
+ ("ghc-tasty" ,ghc-tasty)
("ghc-tasty-hunit" ,ghc-tasty-hunit)
- ("ghc-quickcheck" ,ghc-quickcheck)
- ("ghc-smallcheck" ,ghc-smallcheck)))
- (home-page "https://github.com/phadej/integer-logarithms")
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
+ ("ghc-tasty-smallcheck" ,ghc-tasty-smallcheck)))
+ (home-page "https://github.com/Bodigrim/integer-logarithms")
(synopsis "Integer logarithms")
(description
"This package provides the following modules: