summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-08-26 15:57:51 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-01 23:08:31 +0200
commit770e3b535e0c90764ce58ee8bfb2d68bc0324f7a (patch)
tree60305c6e16e609ebeb2639831d10d6e971cfd17a
parent461fb8598efc319a61d3be0996a4f7d402839539 (diff)
gnu: Add ruby-pdf-core.
* gnu/packages/ruby.scm (ruby-pdf-core): New variable.
-rw-r--r--gnu/packages/ruby.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 1ea41109cc..c21e4cc2d4 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5516,3 +5516,23 @@ access to the contents of a PDF file with a high degree of flexibility.")
use in testing PDF output. Presently, the primary purpose of this tool is to
support the tests found in Prawn, a pure Ruby PDF generation library.")
(license license:gpl3+)))
+
+(define-public ruby-pdf-core
+ (package
+ (name "ruby-pdf-core")
+ (version "0.8.1")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "pdf-core" version))
+ (sha256
+ (base32
+ "15d6m99bc8bbzlkcg13qfpjjzphfg5x905pjbfygvpcxsm8gnsvg"))))
+ (build-system ruby-build-system)
+ (arguments
+ ; No test target
+ `(#:tests? #f))
+ (home-page "https://github.com/prawnpdf/pdf-core")
+ (synopsis "Low level PDF features for Prawn")
+ (description "This is an experimental gem that extracts low-level PDF
+functionality from Prawn.")
+ (license license:gpl3+)))