summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-10-01 16:34:13 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:15 +0100
commit7928ac9370548b407cfae51e8668c2e92e390beb (patch)
treedff617cf006f0e5efa0d94228e0014a25ecc9b35
parent1ed89fc485fb6f04c882ab445ddc70106c5478f0 (diff)
gnu: Add plasma-redshift-control.
* gnu/packages/kde-plasma.scm (plasma-redshift-control): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
-rw-r--r--gnu/packages/kde-plasma.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 1fa41e5004..0771abe67a 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -2074,6 +2074,29 @@ adding, modifying and removing contacts.")
and customizable platform for mobile devices.")
(license (list license:gpl3+ license:lgpl2.1+))))
+(define-public plasma-redshift-control
+ (let ((commit "d9f38a5f0bcf030be16db1776166581c16e802cb")
+ (revision "1"))
+ (package
+ (name "plasma-redshift-control")
+ (version (git-version "0.1-pre" revision commit))
+ (home-page "https://invent.kde.org/plasma/plasma-redshift-control")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1wadxhy6iljhikfw2rbj9dhwb86f2sgwyf62r7sfq6cszcpgp0xi"))))
+ (build-system qt-build-system)
+ (native-inputs (list extra-cmake-modules pkg-config))
+ (inputs (list kwindowsystem plasma-framework redshift))
+ (synopsis "Adjust color temperature")
+ (description
+ "This package provides color temperature control applet for the Plasma
+Desktop.")
+ (license (list license:lgpl2.1 license:lgpl3)))))
+
(define-public plasma-vault
(package
(name "plasma-vault")