summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2023-01-08 10:30:40 +0100
committerMathieu Othacehe <othacehe@gnu.org>2023-01-08 17:46:50 +0100
commit7a9edf4324731fe77c652a9dddff61dfa859e0c4 (patch)
tree2aa4922f3a198a84f7edc1a5dd47ec4c80308c29
parent62c446a4fd0f86f454f5ba5f4221c68e8785201b (diff)
gnu: Add libfreeaptx.
* gnu/packages/audio.scm (libfreeaptx): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/audio.scm33
1 files changed, 32 insertions, 1 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 0cefc61ca2..d72cf0ca87 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2018, 2019, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2018, 2021 Thorsten Wilms <t_w_@freenet.de>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2018, 2022 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019, 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
@@ -4977,6 +4977,37 @@ library supports sample rates up to 96 kHz and up to eight channels (7.1
(license (license:fsf-free "https://github.com/mstorsjo/fdk-aac/blob/master/NOTICE"
"https://www.gnu.org/licenses/license-list.html#fdk"))))
+(define-public libfreeaptx
+ (package
+ (name "libfreeaptx")
+ (version "0.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/iamthehorker/libfreeaptx")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1fm5041nd08yzg0m9474g0943lb3x54zmn59b53nhvxan8x22ibq"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ;no tests.
+ #:make-flags
+ #~(list
+ (string-append "PREFIX=" #$output)
+ (string-append "LDFLAGS=" "-Wl,-rpath=" #$output "/lib")
+ (string-append "CC=" #$(cc-for-target)))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://github.com/iamthehorker/libfreeaptx")
+ (synopsis "aptX codec library")
+ (description "libfreeaptx is an implementation of the Audio Processing
+Technology codecs aptX and aptX HD, mainly intended for use with an A2DP
+bluetooth profile.")
+ (license license:lgpl2.1+)))
+
(define-public libopenshot-audio
(package
(name "libopenshot-audio")