summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Sassmannshausen <alex@pompo.co>2016-11-12 13:26:21 +0100
committerAlex Sassmannshausen <alex@pompo.co>2016-11-12 18:26:28 +0100
commit8883b30165ca1eeee0d852c58a07241a97714771 (patch)
tree656dc480018a358e6f1ae78ab8e69dbff632cc14
parent5c66314bd98e4eb27f88a750cdd2812c62671fc6 (diff)
gnu: Add perl-modern-perl.
* gnu/packages/perl.scm (perl-modern-perl): New variable.
-rw-r--r--gnu/packages/perl.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 6b3d0a7868..edd51be016 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -3506,6 +3506,31 @@ just write a method to handle handles, and methods for handling strings and
file names are added for you.")
(license (package-license perl))))
+(define-public perl-modern-perl
+ (package
+ (name "perl-modern-perl")
+ (version "1.20150127")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/C/CH/CHROMATIC/Modern-Perl-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0iv2crfxl3xh6mq36g1gv9fr8iqq3kpbj8afxy5qi60hh7v3xhcl"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ (home-page
+ "http://search.cpan.org/dist/Modern-Perl")
+ (synopsis
+ "Enable all of the features of Modern Perl with one import")
+ (description "@code{Modern::Perl} provides a simple way to enable
+multiple, by now, standard libraries in a Perl program.")
+ (license (package-license perl))))
+
(define-public perl-module-build-tiny
(package
(name "perl-module-build-tiny")