summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-23 18:01:16 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-23 18:13:30 +0100
commit8b89dedc376d4a3526568da43b9dc4c91d9809ab (patch)
tree24a09ac7a75d5b275e5e2ca250da51b1e8b23296
parent21ccc01d4c7fdddf8b956d6433ad980a78132b89 (diff)
gnu: Add python-sh.
* gnu/packages/python-xyz.scm (python-sh): New variable.
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 42b5a097ae..c01afdd191 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -434,6 +434,24 @@ concepts.")
(define-public python2-h5py
(package-with-python2 python-h5py))
+(define-public python-sh
+ (package
+ (name "python-sh")
+ (version "1.12.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sh" version))
+ (sha256
+ (base32
+ "1z2hx357xp3v4cv44xmqp7lli3frndqpyfmpbxf7n76h7s1zaaxm"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/amoffat/sh")
+ (synopsis "Python subprocess replacement")
+ (description "This package provides a replacement for Python's
+@code{subprocess} feature.")
+ (license license:expat)))
+
(define-public python-netcdf4
(package
(name "python-netcdf4")