summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-02-08 15:36:47 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-02-09 08:44:57 +0300
commit8d0edc8246389c0f2bb1c8e9c9190c312746a4b4 (patch)
treea338efd22d31ddc9c7ed7d64a46ed0641b5f2737
parent63298f14c9679735c6c930e10b0e836666391f01 (diff)
gnu: Add sipcalc.
* gnu/packages/admin.scm (sipcalc): New public variable.
-rw-r--r--gnu/packages/admin.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 60fc41fe01..35e6b202b0 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -523,6 +523,50 @@ and exploration tool, since it can create almost any kind of connection you
would need and has several interesting built-in capabilities.")
(license license:gpl2+)))
+(define-public sipcalc
+ (package
+ (name "sipcalc")
+ (version "1.1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.routemeister.net/projects"
+ "/sipcalc/files/sipcalc" "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0mv3wndj4z2bsshh2k8d5sy3j8wxzgf8mzmmkvj1k8gpcz37dm6g"))))
+ (build-system gnu-build-system)
+ (home-page "http://www.routemeister.net/projects/sipcalc/")
+ (synopsis "Command-line IP subnet calculator")
+ (description
+ "Sipcalc is an advanced command-line IP subnet calculator. It can take
+multiple forms of input (IPv4/IPv6/interface/hostname) and output a multitude
+of information about a given subnet.
+
+Features include:
+
+@itemize @bullet
+@item IPv4
+@itemize
+@item Retrieving of address information from interfaces.
+@item Classfull and CIDR output.
+@item Multiple address and netmask input and output formats (dotted quad, hex,
+number of bits).
+@item Output of broadcast address, network class, Cisco wildcard,
+hosts/range, network range.
+@item The ability to split a network based on a smaller netmask, now also with
+recursive runs on the generated subnets. (also IPv6)
+@end itemize
+@item IPv6
+@itemize
+@item Compressed and expanded input and output addresses.
+@item Standard IPv6 network output.
+@item v4 in v6 output.
+@item Reverse DNS address generation.
+@end itemize
+@end itemize\n")
+ (license license:bsd-3)))
+
(define-public alive
(package
(name "alive")