summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2020-09-14 18:07:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-09-14 21:39:27 +0200
commit916a3e59ab1df1d530f7558b8d653d01a846ee1b (patch)
tree2fea51191bab760379b7ec8747dfd6c4e0f6f2d1
parent6b1946b334b9d3808d78dcd7963c0dab2ce7a908 (diff)
gnu: r-singlecellexperiment: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-singlecellexperiment): Move from here... * gnu/packages/bioconductor.scm (r-singlecellexperiment): ...to here. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/bioconductor.scm29
-rw-r--r--gnu/packages/bioinformatics.scm29
2 files changed, 29 insertions, 29 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 3fec500abb..fbdb7eedb2 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8347,6 +8347,35 @@ routines.")
objects from the @code{graph} package.")
(license license:epl1.0)))
+(define-public r-singlecellexperiment
+ (package
+ (name "r-singlecellexperiment")
+ (version "1.10.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "SingleCellExperiment" version))
+ (sha256
+ (base32
+ "092wvk11n7pa234vlwhxm3gdi4k3sbnz1splhxalbdhz3jf02zfp"))))
+ (properties
+ `((upstream-name . "SingleCellExperiment")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-summarizedexperiment" ,r-summarizedexperiment)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://bioconductor.org/packages/SingleCellExperiment")
+ (synopsis "S4 classes for single cell data")
+ (description "This package defines an S4 class for storing data from
+single-cell experiments. This includes specialized methods to store and
+retrieve spike-in information, dimensionality reduction coordinates and size
+factors for each cell, along with the usual metadata for genes and
+libraries.")
+ (license license:gpl3)))
+
(define-public r-scater
(package
(name "r-scater")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 8dea6df8a1..ef6d6fc2d8 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10791,35 +10791,6 @@ variety of commonly used matrix types, including sparse and HDF5-backed
matrices.")
(license license:gpl3)))
-(define-public r-singlecellexperiment
- (package
- (name "r-singlecellexperiment")
- (version "1.10.1")
- (source
- (origin
- (method url-fetch)
- (uri (bioconductor-uri "SingleCellExperiment" version))
- (sha256
- (base32
- "092wvk11n7pa234vlwhxm3gdi4k3sbnz1splhxalbdhz3jf02zfp"))))
- (properties
- `((upstream-name . "SingleCellExperiment")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-biocgenerics" ,r-biocgenerics)
- ("r-s4vectors" ,r-s4vectors)
- ("r-summarizedexperiment" ,r-summarizedexperiment)))
- (native-inputs
- `(("r-knitr" ,r-knitr)))
- (home-page "https://bioconductor.org/packages/SingleCellExperiment")
- (synopsis "S4 classes for single cell data")
- (description "This package defines an S4 class for storing data from
-single-cell experiments. This includes specialized methods to store and
-retrieve spike-in information, dimensionality reduction coordinates and size
-factors for each cell, along with the usual metadata for genes and
-libraries.")
- (license license:gpl3)))
-
(define-public r-dropbead
(let ((commit "d746c6f3b32110428ea56d6a0001ce52a251c247")
(revision "2"))