summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-23 18:12:11 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-23 18:13:30 +0100
commit93e7b2099b36234056d50438fef053df5d0ca60e (patch)
tree807028e19c3431c7a65e9a0d91f8b4fb952d2a64
parentd362b11d2a5f9b5a03914b3249568bdec19f7951 (diff)
gnu: python-netcdf4: Update to 1.4.2.
* gnu/packages/python-xyz.scm (python-netcdf4): Update to 1.4.2. [arguments]: Remove custom "check" phase; add "configure-locations" phase. [propagated-inputs]: Add python-cftime.
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 12 insertions, 19 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7e3d96c84a..a8637d4af3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -483,39 +483,32 @@ of the netcdf4 package before.")
(define-public python-netcdf4
(package
(name "python-netcdf4")
- (version "1.2.9")
+ (version "1.4.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "netCDF4" version))
(sha256
(base32
- "1h6jq338amlbk0ilzvjyl7cck80i0bah9a5spn9in71vy2qxm7i5"))))
+ "0c0sklgrmv15ygliin8qq0hp7vanmbi74m6zpi0r1ksr0hssyd5r"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'configure-locations
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "HDF5_DIR" (assoc-ref inputs "hdf5"))
+ #t)))))
(native-inputs
`(("python-cython" ,python-cython)))
(propagated-inputs
- `(("python-numpy" ,python-numpy)))
+ `(("python-numpy" ,python-numpy)
+ ("python-cftime" ,python-cftime)))
(inputs
`(("netcdf" ,netcdf)
("hdf4" ,hdf4)
("hdf5" ,hdf5)))
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (setenv "NO_NET" "1") ; disable opendap tests
- (with-directory-excursion "test"
- (setenv "PYTHONPATH" ; find and add the library we just built
- (string-append
- (car (find-files "../build" "lib.*"
- #:directories? #:t
- #:fail-on-error? #:t))
- ":" (getenv "PYTHONPATH")))
- (zero? (system* "python" "run_all.py"))))))))
- (home-page
- "https://github.com/Unidata/netcdf4-python")
+ (home-page "https://github.com/Unidata/netcdf4-python")
(synopsis "Python/numpy interface to the netCDF library")
(description "Netcdf4-python is a Python interface to the netCDF C
library. netCDF version 4 has many features not found in earlier