summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-11-30 10:49:02 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-30 22:06:27 +0100
commit9c8ac92eb6029bb7abdb780e8eba89ceea3655df (patch)
tree75caf6fdf4b2b9efa9443f03ccafb0301b898941
parente318c3a6aa7b0bc07d84ccbdf8d1ca90a39d34d3 (diff)
gnu: Add python-poetry-core.
* gnu/packages/python-xyz.scm (python-poetry-core): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index affeeb080e..6580d22994 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13185,6 +13185,26 @@ powerful API: thread-safety; decorator syntax; support for memcached, redis,
database, file, dict stores. Cachy supports python versions 2.7+ and 3.2+.")
(license license:expat)))
+(define-public python-poetry-core
+ (package
+ (name "python-poetry-core")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "poetry-core" version))
+ (sha256
+ (base32 "1mgv276h1iphn5fqhp2sgkgd5d0c39hs33vgaf157x5ri7rlyrka"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/python-poetry/poetry-core")
+ (synopsis "Poetry PEP 517 build back-end")
+ (description
+ "The @code{poetry-core} module provides a PEP 517 build back-end
+implementation developed for Poetry. This project is intended to be
+a light weight, fully compliant, self-contained package allowing PEP 517
+compatible build front-ends to build Poetry managed projects.")
+ (license license:expat)))
+
(define-public poetry
(package
(name "poetry")