summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLibreMiami <packaging-guix@libremiami.org>2021-02-25 01:46:15 +0000
committerJulien Lepiller <julien@lepiller.eu>2021-02-25 13:59:31 +0100
commita2ece4da1fdccb9e94681e38a3f3a79b0d43e061 (patch)
tree712ff8457f9d888f90b943b3cebcac822ddbcb9a
parent851abe022016549db0aaabf3d5a989777a651b64 (diff)
gnu: Add go-github-com-operatorfoundation-ed25519.
* gnu/packages/golang.scm (go-github-com-operatorfoundation-ed25519): New variable. Co-authored-by: jgart <jgart@dismail.de> Co-authored-by: Julien Lepiller <julien@lepiller.eu> Co-authored-by: Ryan Prior <rprior@protonmail.com> Co-authored-by: Raghav Gururajan <rg@raghavgururajan.name> Co-authored-by: Yasuaki Kudo <yasu@yasuaki.com> Co-authored-by: Stephen Paul Weber <singpolyma@singpolyma.net> Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/golang.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1b4be8acca..e54496c9aa 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6739,3 +6739,34 @@ compressed streams in Go.")
(synopsis "Go library to get configuration values from gitconfig")
(description "@{gitconfig} is a package to get configuration values from gitconfig.")
(license license:expat)))
+
+(define-public go-github-com-operatorfoundation-ed25519
+ (let ((commit "b22b4bd3ddef042eec45f3ee135cd40281fde2b4")
+ (revision "0"))
+ (package
+ (name "go-github-com-operatorfoundation-ed25519")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OperatorFoundation/ed25519")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xrzqrjlghkgd1cy5rj4khryn4f59vas2vzrxc6d8jpj5ijf3xkv"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/OperatorFoundation/ed25519"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'remove-test-data
+ (lambda* (#:key import-path #:allow-other-keys)
+ (delete-file-recursively
+ (string-append "src/" import-path "/testdata"))
+ #t)))))
+ (home-page "https://github.com/OperatorFoundation/ed25519")
+ (synopsis "Ed25519 for go")
+ (description "Package ed25519 implements the Ed25519 signature
+algorithm.")
+ (license license:bsd-3))))