summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2016-02-13 18:57:11 -0800
committerChristopher Allan Webber <cwebber@dustycloud.org>2016-02-21 18:59:39 -0800
commitae00a41febeb56a6844f982e45e52d6ced62b612 (patch)
tree07d130472bb25c82cbcfa4972e7ca1c115afbaae
parentb32a1e47a9d473001a332ad07122947c55558be0 (diff)
gnu: Add python-waitress.
* gnu/packages/python.scm (python-waitress, python2-waitress): New variables.
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b099fcf041..76638cb5a7 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7682,3 +7682,28 @@ templates into Python modules.")
(native-inputs
(cons `("python2-setuptools" ,python2-setuptools)
(package-native-inputs base))))))
+
+(define-public python-waitress
+ (package
+ (name "python-waitress")
+ (version "0.8.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "waitress" version))
+ (sha256
+ (base32
+ "017n9ra6vvmq9d5sfhdzyzr1mg15x2hj2dhm4pdlw98c1ypw2h3w"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/Pylons/waitress")
+ (synopsis "Waitress WSGI server")
+ (description "Waitress is meant to be a production-quality pure-Python WSGI
+server with very acceptable performance.")
+ (license zpl2.1)
+ (properties `((python2-variant . ,(delay python2-waitress))))))
+
+(define-public python2-waitress
+ (package
+ (inherit (package-with-python2
+ (strip-python2-variant python-waitress)))
+ (native-inputs `(("python2-setuptools" ,python2-setuptools)))))