summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-18 12:23:32 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-23 21:32:46 -0400
commitb3f4df3f71ea655d08c96a692b2ad189d8be784b (patch)
tree512d134f6a71f769bac83298525a9f4e69e8be82
parent18dc8c6f0f76b8d128638105eebad2895f9857f0 (diff)
build: Add doc-update-po as a prerequisite to the dist target.
Otherwise 'make dist' would fail with the message: "No rule to make target 'po/doc/guix-manual.pot', needed by 'distdir-am'. Stop.". * Makefile.am (dist) <doc-po-update>: Add prerequisite. (dist-hook) <doc-po-update>: Remove prerequisite.
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 17ad236655..5600bd5503 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -746,9 +746,12 @@ guix-binary.%.tar.xz:
cp "$$tarball" "$@.tmp" ; mv "$@.tmp" "$@"
+# The dependency on doc-po-update is to generate the .pot files, which are not
+# checked in.
+dist: doc-po-update
+
dist-hook: gen-ChangeLog gen-AUTHORS gen-tarball-version
dist-hook: assert-no-store-file-names
-dist-hook: doc-po-update
distcheck-hook: assert-binaries-available assert-final-inputs-self-contained