summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-08-29 14:30:49 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-08-29 15:05:25 +0300
commitcb298154b30aebf711f6d43156df683c38de4ad9 (patch)
treeff3db64d8f3bbef0ab0cda272e12ec4dfb2d9529
parent4247954bbc28d83ece158c4732030d65fdf6b8a5 (diff)
gnu: Add rust-futures-cpupool.
* gnu/packages/crates-io.scm (rust-futures-cpupool): New variable.
-rw-r--r--gnu/packages/crates-io.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 219bbe280a..ac925e3c10 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -593,6 +593,31 @@ featuring zero allocations, composability, and iterator-like interfaces.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-futures-cpupool
+ (package
+ (name "rust-futures-cpupool")
+ (version "0.1.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "futures-cpupool" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1r32456gpblzfvnkf60545v8acqk7gh5zhyhi1jn669k9gicv45b"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-futures" ,rust-futures)
+ ("rust-num-cpus" ,rust-num-cpus))))
+ (home-page "https://github.com/alexcrichton/futures-rs")
+ (synopsis "Implementation of thread pools which hand out futures")
+ (description
+ "An implementation of thread pools which hand out futures to the results of
+the computation on the threads themselves.")
+ (license (list license:asl2.0
+ license:expat))))
+
(define-public rust-futures-io-preview
(package
(name "rust-futures-io-preview")