summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin Lemonnier <lemonnierk@ulrar.net>2014-09-08 21:06:31 +0200
committerLudovic Courtès <ludo@gnu.org>2014-09-09 09:50:19 +0200
commitcf31157fb2ae955f5a996b8831283cb9dcc0cd15 (patch)
treead74a3bbbe5228eaeab9cab645a053eb2de0f9f3
parent42d10464bedb43a9211d8bc187e668fe33272368 (diff)
gnu: Add zsh.
* gnu/packages/zsh.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/zsh.scm73
2 files changed, 74 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index b3d6123468..86b18b5b8f 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -256,6 +256,7 @@ GNU_SYSTEM_MODULES = \
gnu/packages/yasm.scm \
gnu/packages/zile.scm \
gnu/packages/zip.scm \
+ gnu/packages/zsh.scm \
\
gnu/services.scm \
gnu/services/avahi.scm \
diff --git a/gnu/packages/zsh.scm b/gnu/packages/zsh.scm
new file mode 100644
index 0000000000..778085c3c2
--- /dev/null
+++ b/gnu/packages/zsh.scm
@@ -0,0 +1,73 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Kevin Lemonnier <lemonnierk@ulrar.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages zsh)
+ #:use-module (gnu packages ncurses)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages pcre)
+ #:use-module (gnu packages autotools)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix licenses))
+
+(define-public zsh
+ (package
+ (name "zsh")
+ (version "5.0.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.zsh.org/pub/zsh-" version
+ ".tar.gz"))
+ (sha256
+ (base32 "0f9y2lkv6xs5nxgj7ld7sbncy454sgamz21fm4109mxqlqa32fph"))))
+ (build-system gnu-build-system)
+ (arguments `(#:configure-flags '("--with-tcsetpgrp" "--enable-pcre")
+ #:phases (alist-cons-before
+ 'configure 'fix-sh
+ (lambda _
+ (substitute*
+ '("configure"
+ "configure.ac"
+ "Src/exec.c"
+ "Src/mkmakemod.sh"
+ "Config/installfns.sh"
+ "Config/defs.mk.in"
+ "Test/E01options.ztst"
+ "Test/A05execution.ztst"
+ "Test/A01grammar.ztst"
+ "Test/B02typeset.ztst"
+ "Completion/Unix/Command/_init_d"
+ "Util/preconfig")
+ (("/bin/sh") (which "sh"))))
+ %standard-phases)))
+ (native-inputs `(("autoconf", autoconf)))
+ (inputs `(("ncurses", ncurses)
+ ("pcre", pcre)
+ ("perl", perl)))
+ (synopsis "Powerful shell for interactive use and scripting")
+ (description "The Z shell (zsh) is a Unix shell that can be used
+as an interactive login shell and as a powerful command interpreter
+for shell scripting. Zsh can be thought of as an extended Bourne shell
+with a large number of improvements, including some features of bash,
+ksh, and tcsh.")
+ (home-page "http://www.zsh.org/")
+
+ ;; The whole thing is under an MIT/X11-style license, but there's one
+ ;; command, 'Completion/Unix/Command/_darcs', which is under GPLv2+.
+ (license gpl2+)))