summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2019-12-16 16:25:17 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-16 17:30:33 +0100
commitdb6bd842aa4a6254b185740bda36f01c83cd9779 (patch)
tree695bb1aabf6acfd539233a2f66785043860e3c6e
parentdbcef44a0bdc5472cd49cd02d9d11a9c5ff037c9 (diff)
gnu: Add python-argh.
* gnu/packages/python-xyz.scm (python-argh): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/python-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2ec13b7c15..e1c5c60f10 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16826,3 +16826,39 @@ services to what you expect in your tests.")
"This package helps you to capture the standard out (stdout) and the
standard error channel (stderr) in your program.")
(license license:expat))))
+
+(define-public python-argh
+ ;; There are 21 commits since the latest release containing important
+ ;; improvements.
+ (let ((commit "dcd3253f2994400a6a58a700c118c53765bc50a4")
+ (revision "1"))
+ (package
+ (name "python-argh")
+ (version (git-version "0.26.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/neithere/argh.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1p5h3dnpbsjmqrvil96s71asc6i3gpinmbrabqmwnrsxprz7r3ns"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-iocapture" ,python-iocapture)
+ ("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-xdist" ,python-pytest-xdist)
+ ("python-tox" ,python-tox)))
+ (home-page "https://github.com/neithere/argh/")
+ (synopsis "Argparse wrapper with natural syntax")
+ (description
+ "python-argh is a small library that provides several layers of
+abstraction on top of @code{python-argparse}. The layers can be mixed. It is
+always possible to declare a command with the highest possible (and least
+flexible) layer and then tune the behaviour with any of the lower layers
+including the native API of @code{python-argparse}.")
+ (license license:lgpl3+))))