summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-07-23 19:35:53 +0200
committerMarius Bakke <marius@gnu.org>2020-07-23 19:35:53 +0200
commite165a2492d73d37c8b95d6970d453b9d88911ee6 (patch)
treef0ec191e98f585da42221c3d8b71cc67c75eddce
parent7235ce224e3d20b5f73474cac2d3b34b50d754a5 (diff)
gnu: ungoogled-chromium: Avoid top-level reference to LLD.
* gnu/packages/chromium.scm (lld-as-ld, lld-wrapper, lld/wrapped): Move into ... (make-lld-wrapper): ... here. New procedure.
-rw-r--r--gnu/packages/chromium.scm32
1 files changed, 16 insertions, 16 deletions
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index 7955981261..d828c25bc2 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -423,21 +423,21 @@ chromium-fix-vaapi-on-intel.patch?h=packages/chromium\
;; 'make-ld-wrapper' can only work with an 'ld' executable, so we need
;; this trick to make it wrap 'lld'.
-(define lld-as-ld
- (computed-file "lld-ld"
- #~(begin
- (mkdir #$output)
- (mkdir (string-append #$output "/bin"))
- (symlink #$(file-append lld "/bin/lld")
- (string-append #$output "/bin/ld")))))
-
-;; Create a wrapper for LLD that inserts appropriate -rpath entries.
-(define lld-wrapper
- (make-ld-wrapper "lld-wrapper"
- #:binutils lld-as-ld))
-
-;; Clang looks for an 'ld.lld' executable, so we need to symlink it back.
-(define lld/wrapped
+(define (make-lld-wrapper lld)
+ (define lld-as-ld
+ (computed-file "lld-ld"
+ #~(begin
+ (mkdir #$output)
+ (mkdir (string-append #$output "/bin"))
+ (symlink #$(file-append lld "/bin/lld")
+ (string-append #$output "/bin/ld")))))
+
+ ;; Create a wrapper for LLD that inserts appropriate -rpath entries.
+ (define lld-wrapper
+ (make-ld-wrapper "lld-wrapper"
+ #:binutils lld-as-ld))
+
+ ;; Clang looks for an 'ld.lld' executable, so we need to symlink it back.
(computed-file "lld-wrapped"
#~(begin
(mkdir #$output)
@@ -788,7 +788,7 @@ chromium-fix-vaapi-on-intel.patch?h=packages/chromium\
("clang" ,clang-10)
("gn" ,gn)
("gperf" ,gperf)
- ("ld-wrapper" ,lld/wrapped)
+ ("ld-wrapper" ,(make-lld-wrapper lld))
("ninja" ,ninja)
("node" ,node)
("pkg-config" ,pkg-config)