summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2014-09-29 23:46:12 +0400
committerAlex Kost <alezost@gmail.com>2014-09-30 08:50:35 +0400
commite596ab0f246af517209142285d6fb0a2716c4007 (patch)
tree9b45763d40a175b1e5a21590172501ccb698a80d
parent1b3e968512ebbccf02d00c52f7e089156946f445 (diff)
gnu: Move giflib to (gnu packages image).
* gnu/packages/giflib.scm: Remove. Move the contents to (gnu packages image). * gnu-system.am (GNU_SYSTEM_MODULES): Remove giflib file name. * gnu/packages/emacs.scm: Remove giflib module name. * gnu/packages/image.scm (giflib): New variable.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/emacs.scm1
-rw-r--r--gnu/packages/giflib.scm76
-rw-r--r--gnu/packages/image.scm55
4 files changed, 53 insertions, 80 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 43ea9a22e4..b2ad29ae30 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -99,7 +99,6 @@ GNU_SYSTEM_MODULES = \
gnu/packages/geeqie.scm \
gnu/packages/gettext.scm \
gnu/packages/ghostscript.scm \
- gnu/packages/giflib.scm \
gnu/packages/gimp.scm \
gnu/packages/gkrellm.scm \
gnu/packages/gl.scm \
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 6e42d0ac67..1b90bada02 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -34,7 +34,6 @@
#:use-module (gnu packages xorg)
#:use-module (gnu packages lesstif)
#:use-module (gnu packages image)
- #:use-module (gnu packages giflib)
#:use-module (gnu packages linux)
#:use-module (gnu packages version-control)
#:use-module (gnu packages imagemagick)
diff --git a/gnu/packages/giflib.scm b/gnu/packages/giflib.scm
deleted file mode 100644
index 849586ed71..0000000000
--- a/gnu/packages/giflib.scm
+++ /dev/null
@@ -1,76 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages giflib)
- #:use-module (guix licenses)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu)
- #:use-module (srfi srfi-1)
- #:use-module (gnu packages xorg)
- #:use-module (gnu packages perl))
-
-(define-public giflib
- (package
- (name "giflib")
- (version "4.2.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/giflib/giflib-"
- (first (string-split version #\.))
- ".x/giflib-" version ".tar.bz2"))
- (sha256
- (base32 "0rmp7ipzk42r841bggd7bfqk4p8qsssbp4wcck4qnz7p4rkxbj0a"))))
- (build-system gnu-build-system)
- (outputs '("bin" ; utility programs
- "out")) ; library
- (inputs `(("libx11" ,libx11)
- ("libice" ,libice)
- ("libsm" ,libsm)
- ("perl" ,perl)))
- (arguments
- `(#:phases (alist-cons-after
- 'unpack 'disable-html-doc-gen
- (lambda _
- (substitute* "doc/Makefile.in"
- (("^all: allhtml manpages") "")))
- (alist-cons-after
- 'install 'install-manpages
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((bin (assoc-ref outputs "bin"))
- (man1dir (string-append bin "/share/man/man1")))
- (mkdir-p man1dir)
- (for-each (lambda (file)
- (let ((base (basename file)))
- (format #t "installing `~a' to `~a'~%"
- base man1dir)
- (copy-file file
- (string-append
- man1dir "/" base))))
- (find-files "doc" "\\.1"))))
- %standard-phases))))
- (synopsis "Tools and library for working with GIF images")
- (description
- "giflib is a library for reading and writing GIF images. It is API and
-ABI compatible with libungif which was in wide use while the LZW compression
-algorithm was patented. Tools are also included to convert, manipulate,
-compose, and analyze GIF images.")
- (home-page "http://giflib.sourceforge.net/")
- (license x11)))
-
-;;; giflib.scm ends here
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 0e79942f19..1b15be3d24 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1,5 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014 Alex Kost <alezost@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,12 +26,13 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages ghostscript) ;lcms
#:use-module (gnu packages xorg)
- #:use-module (gnu packages giflib)
+ #:use-module (gnu packages perl)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
- #:use-module (guix build-system cmake))
+ #:use-module (guix build-system cmake)
+ #:use-module (srfi srfi-1))
(define-public libpng
(package
@@ -216,6 +219,54 @@ error-resilience, a Java-viewer for j2k-images, ...")
(home-page "http://jbig2dec.sourceforge.net/")
(license license:bsd-2)))
+(define-public giflib
+ (package
+ (name "giflib")
+ (version "4.2.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/giflib/giflib-"
+ (first (string-split version #\.))
+ ".x/giflib-" version ".tar.bz2"))
+ (sha256
+ (base32 "0rmp7ipzk42r841bggd7bfqk4p8qsssbp4wcck4qnz7p4rkxbj0a"))))
+ (build-system gnu-build-system)
+ (outputs '("bin" ; utility programs
+ "out")) ; library
+ (inputs `(("libx11" ,libx11)
+ ("libice" ,libice)
+ ("libsm" ,libsm)
+ ("perl" ,perl)))
+ (arguments
+ `(#:phases (alist-cons-after
+ 'unpack 'disable-html-doc-gen
+ (lambda _
+ (substitute* "doc/Makefile.in"
+ (("^all: allhtml manpages") "")))
+ (alist-cons-after
+ 'install 'install-manpages
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((bin (assoc-ref outputs "bin"))
+ (man1dir (string-append bin "/share/man/man1")))
+ (mkdir-p man1dir)
+ (for-each (lambda (file)
+ (let ((base (basename file)))
+ (format #t "installing `~a' to `~a'~%"
+ base man1dir)
+ (copy-file file
+ (string-append
+ man1dir "/" base))))
+ (find-files "doc" "\\.1"))))
+ %standard-phases))))
+ (synopsis "Tools and library for working with GIF images")
+ (description
+ "giflib is a library for reading and writing GIF images. It is API and
+ABI compatible with libungif which was in wide use while the LZW compression
+algorithm was patented. Tools are also included to convert, manipulate,
+compose, and analyze GIF images.")
+ (home-page "http://giflib.sourceforge.net/")
+ (license license:x11)))
+
(define-public imlib2
(package
(name "imlib2")