summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-11-14 15:39:49 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-11-14 15:43:46 +0200
commitf572de77c4fda3347bea16b4c86d630b193291dc (patch)
tree774be4e068982d8f78be177304492e5948776349
parentaa5df43668b63993ef6153789b67ab1b040ddb84 (diff)
gnu: tegola: Don't use autogenerated tarball.
* gnu/packages/geo.scm (tegola)[source]: Download using git-fetch.
-rw-r--r--gnu/packages/geo.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 2e5315faff..ade53a503c 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1220,14 +1220,14 @@ extension.")
(name "tegola")
(version "0.7.0")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/go-spatial/tegola/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-spatial/tegola")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "09vnzxfn0r70kmd776kcdfqxhzdj11syxa0b27z4ci1k367v7viw"))))
+ "0agqj1b7l41m0imvxjriw44jcpa99mhq1z1vbsfzjhcr94zhwmfr"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/go-spatial/tegola/cmd/tegola"