summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-03-14 16:25:50 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-04-05 19:47:58 +0200
commitf7b512c0842f19c415c4ada666b30ed7235effcb (patch)
tree7f8929f2333ed15c1ea8d983c721bc7ac80273e7
parent5fe981dc83a2dded5a9b4a479e447642363a4d2f (diff)
gnu: Add java-jakarta-oro.
* gnu/packages/java.scm (java-jakarta-oro): New variable.
-rw-r--r--gnu/packages/java.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 9efb8d2054..280601102b 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -9423,3 +9423,37 @@ different file systems. It presents a uniform view of the files from various
different sources, such as the files on local disk, on an HTTP server, or
inside a Zip archive.")
(license license:asl2.0)))
+
+(define-public java-jakarta-oro
+ (package
+ (name "java-jakarta-oro")
+ (version "2.0.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://archive.apache.org/dist/jakarta/oro/"
+ "jakarta-oro-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0rpmnsskiwmsy8r0sckz5n5dbvh3vkxx8hpm177c754r8xy3qksc"))
+ (modules '((guix build utils)))
+ (snippet
+ `(begin
+ (delete-file (string-append "jakarta-oro-" ,version ".jar"))
+ #t))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:build-target "package"
+ #:tests? #f; tests are run as part of the build process
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'install
+ (install-jars ,(string-append "jakarta-oro-" version))))))
+ (home-page "https://jakarta.apache.org/oro/")
+ (synopsis "Text-processing for Java")
+ (description "The Jakarta-ORO Java classes are a set of text-processing
+Java classes that provide Perl5 compatible regular expressions, AWK-like
+regular expressions, glob expressions, and utility classes for performing
+substitutions, splits, filtering filenames, etc. This library is the successor
+of the OROMatcher, AwkTools, PerlTools, and TextTools libraries originally
+from ORO, Inc.")
+ (license license:asl1.1)))