summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-08-19 14:52:15 +0200
committerMarius Bakke <marius@gnu.org>2020-11-21 01:21:32 +0100
commitfb871c58999119794a80efbd4ac09336498aacaf (patch)
tree57b761ccee6e470c7f1bd819e1b7fd30e3c01aaf
parent53346d033287112fb30263eb5a35cf7f2f5621a0 (diff)
gnu: Add python-boto.
* gnu/packages/python-xyz.scm (python-boto): New public variable.
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f85aac1900..f4d89ccd98 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11023,6 +11023,34 @@ document.")
manipulation library.")
(license license:expat)))
+(define-public python-boto
+ (package
+ (name "python-boto")
+ (version "2.49.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "boto" version))
+ (sha256
+ (base32
+ "0njy09c4wjx7ipxhwi6vv404nflyiasl78vwwxxpclnql903n3ga"))))
+ (build-system python-build-system)
+ (arguments
+ ;; XXX: This package is unmaintained and has problems with newer versions
+ ;; of Python 3 as well as test libraries. 'python-moto' still uses a
+ ;; subset of this library, so keep it around for now, but disable tests.
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("python-paramiko" ,python-paramiko)
+ ("python-requests" ,python-requests)))
+ (home-page "https://github.com/boto/boto")
+ (synopsis "Python interfaces for Amazon Web Services")
+ (description
+ "This package provides various facilities for interacting with Amazon
+Web Services through Python.
+
+This software is unmaintained, and new projects should use @code{boto3} instead.")
+ (license license:expat)))
+
(define-public python-botocore
;; Note: When updating botocore, also make sure that boto3 and awscli
;; are compatible.