summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-12-19 18:41:32 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-12-20 22:47:01 -0500
commit9ce709897e55f9f4e322427e60894485d4551d9c (patch)
tree6bf8b6af857d233464f7d674e1789d73dce41e74
parent0f9cb9b6bd81368f2bcc1a06895ffb45e3d8a24b (diff)
gnu: bpython2: Remove package.
* gnu/packages/python-xyz.scm (bpython2): Remove variable.
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e94fddec4c..626f5b7d79 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18270,37 +18270,6 @@ interpreter. bpython's main features are
@end enumerate")
(license license:expat)))
-(define-public bpython2
- (let ((base (package-with-python2
- (strip-python2-variant bpython))))
- (package (inherit base)
- (name "bpython2")
- (arguments
- `(#:python ,python-2
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-failing-test
- (lambda _
- ;; Remove failing test. FIXME: make it pass
- (delete-file "bpython/test/test_args.py")
- ;; Disable failing test-cases (renaming inhibits they are
- ;; discovered)
- (substitute* "bpython/test/test_curtsies_repl.py"
- (("^(\\s*def )(test_get_last_word_with_prev_line\\W)" _ a b)
- (string-append a "xxx_off_" b))
- (("^(\\s*def )(test_complex\\W)" _ a b)
- (string-append a "xxx_off_" b)))
- #t))
- (add-before 'build 'rename-scripts
- ;; rename the scripts to bypthon2, bpdb2, etc.
- (lambda _
- (substitute* "setup.py"
- (("^(\\s+'bpdb)(\\s+=.*',?)\\s*?$" _ name rest)
- (string-append name "2" rest "\n"))
- (("^(\\s+'bpython)(-\\S+)?(\\s+=.*',?)\\s*?$" _ name sub rest)
- (string-append name "2" (or sub "") rest "\n")))
- #t))))))))
-
(define-public python-pyinotify
(package
(name "python-pyinotify")