summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-16 22:20:19 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-16 23:36:10 +0100
commitfb627203e966ad3ae6fb27ffdafbd56123369043 (patch)
tree3957b0d4fec99079d4ef5743b0cbc1bb611abe7c
parentb4b4a96fe6fad9e9016277a94f4ffe56f23a2326 (diff)
gnu: Add rust-redox-syscall-0.2.
* gnu/packages/crates-io.scm (rust-redox-syscall-0.2): New variable. [rust-redox-syscall-0.1]: Inherit from above.
-rw-r--r--gnu/packages/crates-io.scm32
1 files changed, 25 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index fba00154a4..d5b4370c90 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -31378,10 +31378,34 @@ currently pressed on macOS.")
owned memory.")
(license license:expat)))
+
+(define-public rust-redox-syscall-0.2
+ (package
+ (name "rust-redox-syscall")
+ (version "0.2.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "redox_syscall" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1n878lpw577avdr5dzbkil02xwbx0a57mr2r3dcnnkz28i71wd4l"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-bitflags" ,rust-bitflags-1))))
+ (home-page "https://gitlab.redox-os.org/redox-os/syscall")
+ (synopsis "Rust library to access raw Redox system calls")
+ (description
+ "This package provides a Rust library to access raw Redox system calls.")
+ (license license:expat)))
+
;; This package requires features which are unavailable
;; on the stable releases of Rust.
(define-public rust-redox-syscall-0.1
(package
+ (inherit rust-redox-syscall-0.2)
(name "rust-redox-syscall")
(version "0.1.57")
(source
@@ -31392,13 +31416,7 @@ owned memory.")
(sha256
(base32
"1kh59fpwy33w9nwd5iyc283yglq8pf2s41hnhvl48iax9mz0zk21"))))
- (build-system cargo-build-system)
- (arguments '(#:skip-build? #t))
- (home-page "https://gitlab.redox-os.org/redox-os/syscall")
- (synopsis "Rust library to access raw Redox system calls")
- (description "This package provides a Rust library to access raw Redox
-system calls.")
- (license license:expat)))
+ (arguments '(#:skip-build? #t))))
(define-public rust-redox-termios-0.1
(package