summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-03-26 17:53:59 -0400
committerLeo Famulari <leo@famulari.name>2016-03-27 18:24:19 -0400
commit36c2c8c826336e2476d7cf218f457b39a27415b0 (patch)
treecc177ce9b254c9e885300b88fc4b8cf1b3c06683
parent13bc8d5e4f842fe595306c22c99a5868d8016318 (diff)
gnu: beets: Run tests with python-nose.
* gnu/packages/music.scm (nose)[native-inputs]: Add python-nose. [arguments]: Replace 'check' and use python-nose.
-rw-r--r--gnu/packages/music.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 89f49c6f4d..48d6214e3a 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1274,13 +1274,16 @@ websites such as Libre.fm.")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'set-HOME
- (lambda _ (setenv "HOME" (string-append (getcwd) "/tmp")))))))
+ (lambda _ (setenv "HOME" (string-append (getcwd) "/tmp"))))
+ (replace 'check
+ (lambda _ (zero? (system* "nosetests" "-v")))))))
(native-inputs
`(("python2-beautifulsoup4" ,python2-beautifulsoup4)
("python2-flask" ,python2-flask)
("python2-setuptools" ,python2-setuptools)
("python2-mock" ,python2-mock)
("python2-mpd2" ,python2-mpd2)
+ ("python2-nose" ,python2-nose)
("python2-pathlib" ,python2-pathlib)
("python2-pyxdg" ,python2-pyxdg)
("python2-pyechonest" ,python2-pyechonest)