summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2016-03-26 12:52:07 -0400
committerDavid Thompson <dthompson2@worcester.edu>2016-03-26 13:35:06 -0400
commitefd75ade173a75dfd8521a49afb1eda43926d58d (patch)
tree6a2eb8588362b81ad8baf366ad486b1750ed829f
parenta313e0850cbfd75a7e365359df58272d603c71af (diff)
gnu: sdl2-mixer: Update to 2.0.1.
* gnu/packages/sdl.scm (sdl2-mixer): Update to 2.0.1 and remove bundled libraries in source tarball.
-rw-r--r--gnu/packages/sdl.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index c685b1217e..3df5336d41 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -327,15 +327,19 @@ directory.")
(define-public sdl2-mixer
(package (inherit sdl-mixer)
(name "sdl2-mixer")
- (version "2.0.0")
+ (version "2.0.1")
(source (origin
(method url-fetch)
(uri
(string-append "http://www.libsdl.org/projects/SDL_mixer/release/SDL2_mixer-"
version ".tar.gz"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Remove bundled libraries.
+ '(delete-file-recursively "external"))
(sha256
(base32
- "0nvjdxjchrajrn0jag877hdx9zb788hsd315zzg1lyck2wb0xkm8"))))
+ "0pv9jzjpcjlbiaybvwrb4avmv46qk7iqxlnqrd2dfj82c4mgc92s"))))
(propagated-inputs
(propagated-inputs-with-sdl2 sdl-mixer))))