summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2016-12-18 20:10:15 +0000
committerLudovic Courtès <ludo@gnu.org>2016-12-19 23:57:18 +0100
commit0ed5554a01464965e6d2dc3b2ee0eae4bd3156d5 (patch)
treed80c092c83633bacdadac3a96077a6d40100b4d0
parent58b21e1e093c8b19d968a76eb962574b8d38053f (diff)
gnu: Add c-toxcore.
* gnu/packages/messaging.scm (c-toxcore): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/messaging.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 8660915bb0..4e3cc3098c 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -622,6 +622,48 @@ protocols.")
(license license:gpl3+)
(home-page "https://tox.chat"))))
+;; Some tox clients move to c-toxcore, which seems to be where all the
+;; recent development happens. It is run by the same developers as toxcore,
+;; forked into a group namespace.
+(define-public c-toxcore
+ (package
+ (name "c-toxcore")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/TokTok/c-toxcore/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0dybpz44pi0zm8djppjna0r8yh5wvl3l885dv2f1wp5366bk59n3"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("check" ,check)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libsodium" ,libsodium)
+ ("opus" ,opus)
+ ("libvpx" ,libvpx)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'autoconf
+ ;; The tarball source is not bootstrapped.
+ (lambda _
+ (zero? (system* "autoreconf" "-vfi")))))
+ #:tests? #f)) ; FIXME: Testsuite fails, needs internet connection.
+ (synopsis "Library for the Tox encrypted messenger protocol")
+ (description
+ "Official fork of the C library implementation of the Tox
+encrypted messenger protocol.")
+ (license license:gpl3+)
+ (home-page "https://tox.chat")))
+
(define-public utox
(package
(name "utox")