summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Patterson <ajpatter@uwaterloo.ca>2016-12-14 00:03:24 -0500
committerLudovic Courtès <ludo@gnu.org>2016-12-17 23:13:04 +0100
commit32aa37a2e7a5653915a5c1b1fdef7f726ceaf5d2 (patch)
tree0838988babe54fcc69bedcdcefdca94a01c8e111
parent33a14e29f9a19c9e4e76bbba73e21e22d4bab0b9 (diff)
gnu: Add and use sane-backends-minimal.
* gnu/packages/scanner.scm (sane-backends): Rename to... (sane-backends-minimal): this. Adjust name, source, synopsis and description accordingly. * gnu/packages/cups.scm (hplip): Use 'sane-backends-minimal' instead of 'sane-backends'. * gnu/packages/gnome.scm (colord, simple-scan): Likewise. * gnu/packages/libreoffice.scm (libreoffice): Likewise. * gnu/packages/wine.scm (wine): Likewise. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/cups.scm2
-rw-r--r--gnu/packages/gnome.scm4
-rw-r--r--gnu/packages/libreoffice.scm2
-rw-r--r--gnu/packages/scanner.scm11
-rw-r--r--gnu/packages/wine.scm2
5 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 0a8a10ecb4..baa77f7aac 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -416,7 +416,7 @@ device-specific programs to convert and print many types of files.")
(inputs `(("libjpeg" ,libjpeg)
("cups-minimal" ,cups-minimal)
("libusb" ,libusb)
- ("sane-backends" ,sane-backends)
+ ("sane-backends" ,sane-backends-minimal)
("dbus" ,dbus)
("python-wrapper" ,python-wrapper)
("python" ,python)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0b7dab4672..74d04b24f0 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2433,7 +2433,7 @@ keyboard shortcuts.")
("libusb" ,libusb)
("sqlite" ,sqlite)
("polkit" ,polkit)
- ("sane-backends" ,sane-backends)))
+ ("sane-backends" ,sane-backends-minimal)))
(home-page "http://www.freedesktop.org/software/colord/")
(synopsis "Color management service")
(description "Colord is a system service that makes it easy to manage,
@@ -3570,7 +3570,7 @@ USB transfers with your high-level application or system daemon.")
("cairo" ,cairo)
("gdk-pixbuf" ,gdk-pixbuf)
("gusb" ,gusb)
- ("libsane" ,sane-backends)))
+ ("libsane" ,sane-backends-minimal)))
(native-inputs
`(("gettext" ,gettext-minimal)
("itstool" ,itstool)
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 279e8e2d22..307a54496e 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -784,7 +784,7 @@ and to return information on pronunciations, meanings and synonyms.")
("postgresql" ,postgresql)
("python" ,python)
("redland" ,redland)
- ("sane-backends" ,sane-backends)
+ ("sane-backends" ,sane-backends-minimal)
("unixodbc" ,unixodbc)
("unzip" ,unzip)
("vigra" ,vigra)
diff --git a/gnu/packages/scanner.scm b/gnu/packages/scanner.scm
index 01db5ee210..e913858f51 100644
--- a/gnu/packages/scanner.scm
+++ b/gnu/packages/scanner.scm
@@ -26,15 +26,15 @@
#:use-module ((guix licenses)
#:prefix licence:))
-(define-public sane-backends
+(define-public sane-backends-minimal
(package
- (name "sane-backends")
+ (name "sane-backends-minimal")
(version "1.0.25")
(source (origin
(method url-fetch)
(uri (string-append
"https://alioth.debian.org/frs/download.php/file/4146/"
- name "-" version ".tar.gz"))
+ "sane-backends-" version ".tar.gz"))
(sha256
(base32
"0b3fvhrxl4l82bf3v0j47ypjv6a0k5lqbgknrq1agpmjca6vmmx4"))))
@@ -71,9 +71,10 @@
;; **** File generated for html-backends-split mode is different from reference
;; Makefile:501: recipe for target 'check.local' failed
(home-page "http://www.sane-project.org")
- (synopsis "Raster image scanner library and drivers")
+ (synopsis
+ "Raster image scanner library and drivers, without scanner support")
(description "SANE stands for \"Scanner Access Now Easy\" and is an API
proving access to any raster image scanner hardware (flatbed scanner,
hand-held scanner, video- and still-cameras, frame-grabbers, etc.). The
-package contains the library and drivers.")
+package contains the library, but no drivers.")
(license licence:gpl2+))) ; plus linking exception
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 367f27af5e..83b6297f0c 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -83,7 +83,7 @@
("libmpg123" ,mpg123)
("libldap" ,openldap)
("libnetapi" ,samba)
- ("libsane" ,sane-backends)
+ ("libsane" ,sane-backends-minimal)
("libpng" ,libpng)
("libjpeg" ,libjpeg)
("libtiff" ,libtiff)