summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-09 13:55:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-15 22:33:15 +0200
commit65214c872a2c75f51e2243b5fee1ecdeebce10b3 (patch)
tree7625fe0126342ae4c78413cfdd9aa67568b49c97
parentfbaf09ebf2f811a983d1d9d48005d662818bddd5 (diff)
gnu: Add java-eclipse-equinox-app.
* gnu/packages/java.scm (java-eclipse-equinox-app): New variable.
-rw-r--r--gnu/packages/java.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 7666138aba..8a7af2d496 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2472,6 +2472,34 @@ specification.")
registry.")
(license license:epl1.0)))
+(define-public java-eclipse-equinox-app
+ (package
+ (name "java-eclipse-equinox-app")
+ (version "1.3.400")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://repo1.maven.org/maven2/"
+ "org/eclipse/platform/org.eclipse.equinox.app/"
+ version "/org.eclipse.equinox.app-"
+ version "-sources.jar"))
+ (sha256
+ (base32
+ "0nhvbp93y203ar7y59gb0mz3w2d3jlqhr0c9hii9bcfpmr7imdab"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:tests? #f ; no tests included
+ #:jar-name "eclipse-equinox-app.jar"))
+ (inputs
+ `(("java-eclipse-equinox-common" ,java-eclipse-equinox-common)
+ ("java-eclipse-equinox-registry" ,java-eclipse-equinox-registry)
+ ("java-eclipse-osgi" ,java-eclipse-osgi)
+ ("java-osgi-service-event" ,java-osgi-service-event)))
+ (home-page "http://www.eclipse.org/equinox/")
+ (synopsis "Equinox application container")
+ (description "This package provides the Equinox application container for
+Eclipse.")
+ (license license:epl1.0)))
+
(define-public java-commons-cli
(package
(name "java-commons-cli")