summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-12-19 21:26:39 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2016-12-20 05:36:57 +0100
commit707ee3247162062ff08ff5fd0aa569d00e914f9d (patch)
tree93c3f1300add9c5bf1d8f9e6e07e5bc3bd5a2d3b
parentf87b8e25c30a7d2b0281cf04645cf3f50f81fa1b (diff)
gnu: aspell-dictionary: Use ‘modify-phases’ syntax.
* gnu/packages/aspell.scm (aspell-dictionary)[arguments]: Use ‘modify-phases’.
-rw-r--r--gnu/packages/aspell.scm24
1 files changed, 13 insertions, 11 deletions
diff --git a/gnu/packages/aspell.scm b/gnu/packages/aspell.scm
index 01a799f9c6..4482138958 100644
--- a/gnu/packages/aspell.scm
+++ b/gnu/packages/aspell.scm
@@ -66,7 +66,8 @@ dictionaries, including personal ones.")
;;;
;;; Dictionaries.
;;;
-;;; Use 'export ASPELL_CONF="dict-dir $HOME/.guix-profile/lib/aspell"' to use them.
+;;; Use 'export ASPELL_CONF="dict-dir $HOME/.guix-profile/lib/aspell"' to use
+;;; them.
;;;
(define* (aspell-dictionary dict-name full-name
@@ -82,16 +83,17 @@ dictionaries, including personal ones.")
(sha256 sha256)))
(build-system gnu-build-system)
(arguments
- `(#:phases (alist-replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (zero? (system* "./configure"))))
- %standard-phases)
- #:make-flags (let ((out (assoc-ref %outputs "out")))
- (list (string-append "dictdir=" out "/lib/aspell")
- (string-append "datadir=" out "/lib/aspell")))
- #:tests? #f))
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (zero? (system* "./configure"))))))
+ #:make-flags
+ (let ((out (assoc-ref %outputs "out")))
+ (list (string-append "dictdir=" out "/lib/aspell")
+ (string-append "datadir=" out "/lib/aspell")))
+ #:tests? #f))
(native-inputs `(("aspell" ,aspell)
("which" ,which)))
(synopsis (string-append full-name " dictionary for GNU Aspell")) ; XXX: i18n