summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-19 18:39:19 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-19 23:43:47 +0100
commit7d0910d4a7670d353f7eeab44ee72e943fed234b (patch)
tree02dd76611de83f3a10a00d1c15c908244150c892
parent7d8f7ab9be28e212280d91b9b1f66127f1bd5616 (diff)
Revert "gnu: grub: Add dependency on efibootmgr."
This reverts commit 3eee16130d858ae96510ec1c7d38d31290de2699. Reverted in favor of separate grub-efi package. See discussion at https://lists.gnu.org/archive/html/guix-devel/2016-12/msg00765.html .
-rw-r--r--gnu/packages/grub.scm9
1 files changed, 0 insertions, 9 deletions
diff --git a/gnu/packages/grub.scm b/gnu/packages/grub.scm
index 866dfcfb25..317ed03573 100644
--- a/gnu/packages/grub.scm
+++ b/gnu/packages/grub.scm
@@ -84,12 +84,6 @@
(assoc-ref inputs "mdadm")
"/sbin/mdadm\"")))
- ;; Ditto for efibootmgr.
- (substitute* "grub-core/osdep/unix/platform.c"
- (("efibootmgr")
- (string-append (assoc-ref inputs "efibootmgr")
- "/sbin/efibootmgr")))
-
;; Make the font visible.
(copy-file (assoc-ref inputs "unifont") "unifont.bdf.gz")
(system* "gunzip" "unifont.bdf.gz")
@@ -104,9 +98,6 @@
(inputs
`(("gettext" ,gettext-minimal)
- ;; For {U,}EFI.
- ("efibootmgr" ,efibootmgr)
-
;; Depend on LVM2 for libdevmapper, used by 'grub-probe' and
;; 'grub-install' to recognize mapped devices (LUKS, etc.)
("lvm2" ,lvm2)