summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-19 23:22:07 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-19 23:43:09 +0100
commit7d8f7ab9be28e212280d91b9b1f66127f1bd5616 (patch)
tree4cce911428b6dfb9799c841b458c65de5c3a4550
parent8d1ef002ee96bbc8909bfbe704ecc1bbaab764d8 (diff)
gnu: grub: Use qemu-minimal for tests.
* gnu/packages/grub.scm (qemu-for-tests): Remove variable. (grub)[native-inputs]: Replace QEMU-FOR-TESTS with QEMU-MINIMAL.
-rw-r--r--gnu/packages/grub.scm35
1 files changed, 2 insertions, 33 deletions
diff --git a/gnu/packages/grub.scm b/gnu/packages/grub.scm
index 83304b8501..866dfcfb25 100644
--- a/gnu/packages/grub.scm
+++ b/gnu/packages/grub.scm
@@ -36,38 +36,7 @@
#:use-module (gnu packages man)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages ncurses)
- #:use-module (gnu packages cdrom)
- #:use-module (srfi srfi-1))
-
-(define qemu-for-tests
- ;; Newer QEMU versions, such as 1.5.1, no longer support the 'shutdown'
- ;; instruction. This leads to test hangs, as reported at
- ;; <https://bugs.launchpad.net/bugs/947597> and fixed at
- ;; <http://bzr.savannah.gnu.org/lh/grub/trunk/grub/revision/4828>.
- ;; Work around it by using an older QEMU.
- (package (inherit qemu-minimal)
- (version "1.3.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://wiki.qemu-project.org/download/qemu-"
- version ".tar.bz2"))
- (sha256
- (base32
- "1bqfrb5dlsxm8gxhkksz8qzi5fhj3xqhxyfwbqcphhcv1kpyfwip"))))
-
- ;; With recent GLib versions, we get a test failure:
- ;; ERROR:tests/rtc-test.c:176:check_time: assertion failed (ABS(t - s) <= wiggle): (382597824 <= 2)
- ;; Simply disable the tests.
- (arguments `(#:tests? #f
- ,@(substitute-keyword-arguments (package-arguments qemu-minimal)
- ((#:phases phases)
- ;; We disable the tests so we also skip the phase disabling
- ;; the qga test, which fails due to changes in QEMU
- `(modify-phases ,phases
- (delete 'disable-test-qga))))))
-
- ;; The manual fails to build with Texinfo 5.x.
- (native-inputs (alist-delete "texinfo" (package-native-inputs qemu)))))
+ #:use-module (gnu packages cdrom))
(define unifont
;; GNU Unifont, <http://gnu.org/s/unifont>.
@@ -160,7 +129,7 @@
;; Dependencies for the test suite. The "real" QEMU is needed here,
;; because several targets are used.
("parted" ,parted)
- ("qemu" ,qemu-for-tests)
+ ("qemu" ,qemu-minimal)
("xorriso" ,xorriso)))
(home-page "https://www.gnu.org/software/grub/")
(synopsis "GRand Unified Boot loader")