summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2016-12-18 20:10:16 +0000
committerLudovic Courtès <ludo@gnu.org>2016-12-19 23:57:18 +0100
commitc413c6ade8530fd3bd5e76c88e0642b7f3b52798 (patch)
tree55650da2466ea0a9f0ed6eab9509d78ef52ac403
parent0ed5554a01464965e6d2dc3b2ee0eae4bd3156d5 (diff)
gnu: utox: Update to 0.11.0.
* gnu/packages/messaging.scm (utox): Update to 0.11.0. [source]: Update source uri to new group namespace on github. [build-system]: Change to cmake-build-system. [arguments]: Remove previous content and disable tests, add two new phases. [inputs]: Remove libtoxcore, add c-toxcore. [native-inputs]: Remove it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/messaging.scm33
1 files changed, 20 insertions, 13 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 4e3cc3098c..2d172d8b03 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -34,6 +34,7 @@
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system python)
#:use-module (guix build-system perl)
+ #:use-module (guix build-system cmake)
#:use-module (gnu packages)
#:use-module (gnu packages aidc)
#:use-module (gnu packages autotools)
@@ -667,46 +668,52 @@ encrypted messenger protocol.")
(define-public utox
(package
(name "utox")
- (version "0.9.8")
+ (version "0.11.0")
(source
(origin
(method url-fetch)
- (uri (string-append "https://github.com/GrayHatter/uTox/archive/v"
+ (uri (string-append "https://github.com/uTox/uTox/archive/v"
version ".tar.gz"))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "13hfqbwzcgvfbvf9yjm62aqsvxnpqppb50c88sys43m7022yqcsy"))))
- (build-system gnu-build-system)
+ "15s4iwjk1s0kihjqn0f07c9618clbphpr827mds3xddkiwnjz37v"))))
+ (build-system cmake-build-system)
(arguments
- '(#:make-flags (list (string-append "PREFIX=" %output)
- "CC=gcc")
- #:tests? #f ; No tests
+ '(#:tests? #f ; No test phase.
#:phases
(modify-phases %standard-phases
- ;; No configure script
- (delete 'configure))))
+ (add-after 'unpack 'fix-freetype-include
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("/usr/include/freetype2")
+ (string-append (assoc-ref %build-inputs "freetype")
+ "/include/freetype2")))))
+ (add-before 'install 'patch-cmake-find-utox
+ (lambda _
+ (substitute* "../build/cmake_install.cmake"
+ (("/uTox-0.11.0/utox")
+ "/build/utox")))))))
(inputs
+ ;; TODO: Fix the file chooser dialog; which input does it need?
`(("dbus" ,dbus)
("filteraudio" ,filteraudio)
("fontconfig" ,fontconfig)
("freetype" ,freetype)
("libsodium" ,libsodium)
- ("libtoxcore" ,libtoxcore)
+ ("c-toxcore" ,c-toxcore)
("libvpx" ,libvpx)
("libx11" ,libx11)
("libxext" ,libxext)
("libxrender" ,libxrender)
("openal" ,openal)
("v4l-utils" ,v4l-utils)))
- (native-inputs
- `(("pkg-config" ,pkg-config)))
(synopsis "Lightweight Tox client")
(description "A lightweight Tox client. Tox is a distributed and secure
instant messenger with audio and video chat capabilities.")
(home-page "http://utox.org/")
(license license:gpl3)))
-
+
(define-public qtox
(package
(name "qtox")