summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-12-20 17:30:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-12-20 17:58:06 +0100
commitc8e2219cfb914429b6409dbef1491652b910f70b (patch)
tree97bb1316cc74cce6d3528554da7970a0ec6a0923
parenta81771f137716c62e7a44355e18ce5487ecf5301 (diff)
gnu: guix: Update to 0.12.0.
* gnu/packages/package-management.scm (guix-0.11.0): Rename to... (guix-0.12.0): ... this. Adjust users. (guix): Set to GUIX-0.12.0.
-rw-r--r--gnu/packages/package-management.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 7083a1664c..bc30cb5f47 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -68,17 +68,17 @@
arch "-linux"
"/20131110/guile-2.0.9.tar.xz")))
-(define-public guix-0.11.0
+(define-public guix-0.12.0
(package
(name "guix")
- (version "0.11.0")
+ (version "0.12.0")
(source (origin
(method url-fetch)
(uri (string-append "ftp://alpha.gnu.org/gnu/guix/guix-"
version ".tar.gz"))
(sha256
(base32
- "1cwrbpv4dq7aczwksmcfw9w8r2bzrb5ld9zvjcr90i804hjpcb93"))))
+ "1jgy5mlygmhxdqhrp6vr8w83ndcm5mk64xfravr8l2d7hq8y40b2"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags (list
@@ -227,7 +227,7 @@ the Nix package manager.")
;; Note: use a very short commit id; with a longer one, the limit on
;; hash-bang lines would be exceeded while running the tests.
(let ((commit "8d125cfc2e5cb0825bb40893ec3e940f85f1b235"))
- (package (inherit guix-0.11.0)
+ (package (inherit guix-0.12.0)
(version (string-append "0.11.0-8." (string-take commit 4)))
(source (origin
(method git-fetch)
@@ -241,7 +241,7 @@ the Nix package manager.")
"0h73m1zad67qqn7ygypcqscicvqj31wwkxsr85d5lr77v6bx7b6z"))
(file-name (string-append "guix-" version "-checkout"))))
(arguments
- (substitute-keyword-arguments (package-arguments guix-0.11.0)
+ (substitute-keyword-arguments (package-arguments guix-0.12.0)
((#:configure-flags flags)
;; Set 'DOT_USER_PROGRAM' to the empty string so we don't keep a
;; reference to Graphviz, whose closure is pretty big (too big for
@@ -259,7 +259,7 @@ the Nix package manager.")
(zero? (system* "sh" "bootstrap")))))))))))
-(define-public guix guix-devel)
+(define-public guix guix-0.12.0)
(define (source-file? file stat)
"Return true if FILE is likely a source file, false if it is a typical