summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-09 18:21:55 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-15 22:33:16 +0200
commite8d0f7c8f9913218452e65d6f891af5773aee38a (patch)
tree722f2616c8aded754232987ffa3486df2931338d
parente96060de2086bcbc8c9f80a56339f87f76389e22 (diff)
gnu: Add java-eclipse-core-variables.
* gnu/packages/java.scm (java-eclipse-core-variables): New variable.
-rw-r--r--gnu/packages/java.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 20259bc699..37a6a04f84 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2642,6 +2642,35 @@ module @code{org.eclipse.core.filesystem}.")
with the @code{org.eclipse.core.expressions} module.")
(license license:epl1.0)))
+(define-public java-eclipse-core-variables
+ (package
+ (name "java-eclipse-core-variables")
+ (version "3.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://repo1.maven.org/maven2/"
+ "org/eclipse/platform/org.eclipse.core.variables/"
+ version "/org.eclipse.core.variables-"
+ version "-sources.jar"))
+ (sha256
+ (base32
+ "12dirh03zi4n5x5cj07vzrhkmnqy6h9q10h9j605pagmpmifyxmy"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:tests? #f ; no tests included
+ #:jar-name "eclipse-core-variables.jar"))
+ (inputs
+ `(("java-eclipse-equinox-common" ,java-eclipse-equinox-common)
+ ("java-eclipse-equinox-registry" ,java-eclipse-equinox-registry)
+ ("java-eclipse-equinox-preferences" ,java-eclipse-equinox-preferences)
+ ("java-eclipse-core-runtime" ,java-eclipse-core-runtime)
+ ("java-eclipse-osgi" ,java-eclipse-osgi)))
+ (home-page "https://www.eclipse.org/platform")
+ (synopsis "Eclipse core variables")
+ (description "This package provides the Eclipse core variables module
+@code{org.eclipse.core.variables}.")
+ (license license:epl1.0)))
+
(define-public java-commons-cli
(package
(name "java-commons-cli")