summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-03-07 19:54:46 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-05-15 22:00:25 +0200
commit4b34c21ff09fe030a2143d9410b5bf81f0978182 (patch)
tree409f6817f98e47f2b83c4c27063c893677974171
parentcbce5de26581f61d05f90740d8478f070762d591 (diff)
gnu: Add java-commons-net.
* gnu/packages/java.scm (java-commons-net): New variable.
-rw-r--r--gnu/packages/java.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 6b36bc6f5e..b05c3cca87 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2164,6 +2164,34 @@ standards and recommendations.")
("java-junit" ,java-junit)
("java-hamcrest-core" ,java-hamcrest-core)))))
+(define-public java-commons-net
+ (package
+ (name "java-commons-net")
+ (version "3.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://apache/commons/net/source/"
+ "commons-net-" version "-src.tar.gz"))
+ (sha256
+ (base32
+ "0n0cmnddk9qdqhjvka8pc6hd9mn2qi3166f1s6xk32h7rfy1adxr"))))
+ (build-system ant-build-system)
+ (arguments
+ `(;; FIXME: MainTest.java tries to read "examples.properties" (which
+ ;; should be "resources/examples/examples.properties"), but gets "null"
+ ;; instead.
+ #:tests? #f
+ #:jar-name "commons-net.jar"))
+ (native-inputs
+ `(("java-junit" ,java-junit)
+ ("java-hamcrest-core" ,java-hamcrest-core)))
+ (home-page "http://commons.apache.org/net/")
+ (synopsis "Client library for many basic Internet protocols")
+ (description "The Apache Commons Net library implements the client side of
+many basic Internet protocols. The purpose of the library is to provide
+fundamental protocol access, not higher-level abstractions.")
+ (license license:asl2.0)))
+
(define-public java-commons-cli
(package
(name "java-commons-cli")