summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-03-07 19:52:23 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-05-15 22:00:00 +0200
commit4f4d2e470ddd72d0a96c4b5a40d9874ee9256a2e (patch)
tree92d965b0ce5053fb1328ea6598a0745f1d2f9aa9
parent90e65abe426828d2077b1ae935f9c2d4075c4d5c (diff)
gnu: Add java-httpcomponents-httpcore.
* gnu/packages/java.scm (java-httpcomponents-httpcore): New variable.
-rw-r--r--gnu/packages/java.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 900dbc8a5c..ee7d7d4af2 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2037,6 +2037,42 @@ tests with a clean and simple API. It generates mocks using reflection, and
it records all mock invocations, including methods arguments.")
(license license:asl2.0)))
+(define-public java-httpcomponents-httpcore
+ (package
+ (name "java-httpcomponents-httpcore")
+ (version "4.4.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://apache//httpcomponents/httpcore/"
+ "source/httpcomponents-core-"
+ version "-src.tar.gz"))
+ (sha256
+ (base32
+ "02bwcf38y4vgwq7kj2s6q7qrmma641r5lacivm16kgxvb2j6h1vy"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "httpcomponents-httpcore.jar"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "httpcore") #t)))))
+ (inputs
+ `(("java-commons-logging-minimal" ,java-commons-logging-minimal)
+ ("java-commons-lang3" ,java-commons-lang3)))
+ (native-inputs
+ `(("java-junit" ,java-junit)
+ ("java-mockito" ,java-mockito-1)))
+ (home-page "https://hc.apache.org/httpcomponents-core-4.4.x/index.html")
+ (synopsis "Low level HTTP transport components")
+ (description "HttpCore is a set of low level HTTP transport components
+that can be used to build custom client and server side HTTP services with a
+minimal footprint. HttpCore supports two I/O models: blocking I/O model based
+on the classic Java I/O and non-blocking, event driven I/O model based on Java
+NIO.
+
+This package provides the blocking I/O model library.")
+ (license license:asl2.0)))
+
(define-public java-commons-cli
(package
(name "java-commons-cli")