summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-07-01 23:51:21 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-07-02 00:45:19 +0200
commit39f516cb839af6be3420ea02705c3f914308b90b (patch)
treea8716a33308cbb79f5ef55dfff6d0187ab33a089
parenta1205efe1130d4084c6205a89108f1b1743ba3d5 (diff)
gnu: godot: Don't use unstable tarball.
* gnu/packages/game-development.scm (godot)[source]: Use GIT-FETCH.
-rw-r--r--gnu/packages/game-development.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 7eba03ea77..a715c958cd 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1064,14 +1064,14 @@ games.")
(name "godot")
(version "3.0.4")
(source (origin
- (method url-fetch)
- (uri
- (string-append "https://github.com/godotengine/godot/archive/"
- version "-stable.tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/godotengine/godot")
+ (commit (string-append version "-stable"))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0khnj9rf24g56imwl78a89f2agxi6arbh804zrv54k79rm71dlpb"))
+ "0i4ssfb6igga9zwvsmahrnasx9cyqrsd6mlmssjgc482fy9q2kz4"))
(modules '((guix build utils)))
(snippet
'(begin