summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Mikkelsen <peter@alaok.org>2018-06-29 14:26:56 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-03 15:45:41 +0200
commitabf3a33178d2b849455fcbf97e710ce062b074df (patch)
tree9b2112012a83b361c9266186f11d714d52c431a9
parentb5f746d2da4e293ec8e704b89118b09aa4b5f94d (diff)
gnu: emacs-use-package: Update to commit da8c9e2.
This update is needed because the release tarball from github does not contain all the files needed for us to build the package. * gnu/packages/emacs.scm (emacs-use-package): Update to commit da8c9e2. [source]: change to git. [arguments]: Enable tests. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/emacs.scm53
1 files changed, 26 insertions, 27 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index a62c0bd8a4..21c0499eff 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -5792,35 +5792,34 @@ abbreviation of the mode line displays (lighters) of minor modes.")
(license license:gpl2+)))
(define-public emacs-use-package
- (package
- (name "emacs-use-package")
- (version "2.3")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/jwiegley/use-package/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0x4h136jb3imyli6zsh7dyzjrra6pv0v6b0yk94jdng3rdfcmsf5"))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-diminish" ,emacs-diminish)))
- (arguments
- ;; Tests fail in this release, but have been fixed in
- ;; upstream commit 7956d40eed57d6c06bef36ebc174cf57d934e30d
- `(#:tests? #f
- #:test-command '("emacs" "--batch"
- "-l" "use-package-tests.el"
- "-f" "ert-run-tests-batch-and-exit")))
- (home-page "https://github.com/jwiegley/use-package")
- (synopsis "Declaration for simplifying your .emacs")
- (description "The use-package macro allows you to isolate package
+ (let ((commit "da8c9e2840343906e732f9699e43d35a1f06481d")
+ (revision "1"))
+ (package
+ (name "emacs-use-package")
+ (version (git-version "2.3" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jwiegley/use-package")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0jz38pbq1p9h85i6qcsh3sfzkd103y6mw3rg5zd14dxigp8ir3xz"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-diminish" ,emacs-diminish)))
+ (arguments
+ `(#:tests? #t
+ #:test-command '("emacs" "--batch"
+ "-l" "use-package-tests.el"
+ "-f" "ert-run-tests-batch-and-exit")))
+ (home-page "https://github.com/jwiegley/use-package")
+ (synopsis "Declaration for simplifying your .emacs")
+ (description "The use-package macro allows you to isolate package
configuration in your @file{.emacs} file in a way that is both
performance-oriented and tidy.")
- (license license:gpl2+)))
+ (license license:gpl2+))))
(define-public emacs-strace-mode
(let* ((commit "6a69b4b06db6797af56f33eda5cb28af94e59f11")