summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-07-03 16:19:24 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-07-03 16:20:28 +0200
commitc7d5cd6ca56241c5a17c2c917f6e03a26a03ee15 (patch)
tree9abdb1b9443148f342d7154b07301c0a23465d9a
parent29cbf8178f7fe97f42005f0d8b32f38c2caee041 (diff)
gnu: pigx-rnaseq: Update to 0.0.4.
* gnu/packages/bioinformatics.scm (pigx-rnaseq): Update to 0.0.4. [arguments]: Remove "wrap-executable" phase.
-rw-r--r--gnu/packages/bioinformatics.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c0ee641e88..e8408b95a4 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12831,7 +12831,7 @@ once. This package provides tools to perform Drop-seq analyses.")
(define-public pigx-rnaseq
(package
(name "pigx-rnaseq")
- (version "0.0.3")
+ (version "0.0.4")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/BIMSBbioinfo/pigx_rnaseq/"
@@ -12839,7 +12839,7 @@ once. This package provides tools to perform Drop-seq analyses.")
"/pigx_rnaseq-" version ".tar.gz"))
(sha256
(base32
- "0pz080k4ajlc4rlznkn3najy2a6874gb56rf9g4ag9wqz31q174j"))))
+ "16gla23rmziimqan7w494q0nr7vfbp42zzkrl9fracmr4k7b1kzr"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-tests? #f ; not supported
@@ -12851,14 +12851,6 @@ once. This package provides tools to perform Drop-seq analyses.")
(substitute* "Makefile.in"
(("(^ tests/test_trim_galore/test.sh).*" _ m) m)
(("^ test.sh") ""))
- #t))
- (add-after 'install 'wrap-executable
- ;; Make sure the executable finds all R modules.
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (wrap-program (string-append out "/bin/pigx-rnaseq")
- `("R_LIBS_SITE" ":" = (,(getenv "R_LIBS_SITE")))
- `("PYTHONPATH" ":" = (,(getenv "PYTHONPATH")))))
#t)))))
(inputs
`(("gzip" ,gzip)