summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-10-21 23:29:17 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-25 22:25:20 -0700
commit00463093981f0b3fb4bf33209bd3364dbf16367d (patch)
treeb324230069d98af2350f46dfb154f314dc0b5ee9
parent7d4147634bca68d38dfc7b7edaf38c7c85029986 (diff)
gnu: Add python-coloredlogs.
* gnu/packages/python.scm (python-coloredlogs, python2-coloredlogs): New variables. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 106b23e902..f003cb2efa 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1183,6 +1183,35 @@ add the log levels NOTICE, SPAM, SUCCESS and VERBOSE.")
(define-public python2-verboselogs
(package-with-python2 python-verboselogs))
+(define-public python-coloredlogs
+ (package
+ (name "python-coloredlogs")
+ (version "7.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "coloredlogs" version))
+ (sha256
+ (base32
+ "1blcann6dyg5dhps9pg12rn0q0rjrlajpmmil0gy0j4cbvnl2il9"))))
+ (build-system python-build-system)
+ (arguments
+ `(;Tests require some updated modules
+ #:tests? #f))
+ (propagated-inputs
+ `(("python-capturer" ,python-capturer)))
+ (home-page "https://coloredlogs.readthedocs.io")
+ (synopsis "Colored stream handler for Python's logging module")
+ (description
+ "The @code{coloredlogs} package enables colored terminal output for
+Python's logging module. The @code{ColoredFormatter} class inherits from
+@code{logging.Formatter} and uses ANSI escape sequences to render your logging
+messages in color.")
+ (license license:expat)))
+
+(define-public python2-coloredlogs
+ (package-with-python2 python-coloredlogs))
+
(define-public python-eventlet
(package
(name "python-eventlet")